Black Screen after update

I upgraded OSMC via GUI last night. During the boot I can see the OSMC welcome screen then all I get is a black screen. I can SSH. I have tried to delete the guisettings.xml but still have a blackscreen. I was using confluence. I want to avoid a re-install as it takes hours to get everything how I like it.

An update message was on my screen asking whether I wanted to update and that it needed to stop Kodi. I selected yes. Everything appears to load. I just get a black screen.

Device: Rasp Pi B
Installation media:SDcard,
Power Supply Type: usb hub
Power specs: 5 v
Peripherals: usb hub ,
Storage Device USB drive
OSMC version: VERSION_ID=“2015.07-1”
XBMC version: 09:03:57 20.314707 T:3023708720 NOTICE: Starting Kodi (15.1-RC1 Git:Unknown). Platform: Linux ARM 32-bit
09:03:57 20.314932 T:3023708720 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)

Codecs: (mpeg2, vc1?)
Audio/Video Output: HDMI
Overclocked: No
Config.txt Extras:

Please tell me how to get the logs you need via SSH

I am not even sure if kodi is starting… :cry:

You could check if it’s running from an SSH login with systemctl list-units |grep media - the kodi stuff is mediacenter.service

That blows. look like it is started
mediacenter.service loaded active running media center application

Enable debug logging, restart your pi, create issue (we’ll assume it boots to black screen), SSH and issue paste-log .kodi/temp/kodi.log then provide the resulting URL here.

not sure if I have done this correctly

MOD EDIT: Removed log spam, use paste site please

No, please provide the link that is returned when you issued the command.


I have the same problem. After major update the mediacenter will launch and accept SSH but no Picture. I cannot enable debug logging as I cannot navigate in OSMC.

You are not following instructions. You have not provided a “debug enabled” log.

17:01:34  22.310177 T:3023745584  NOTICE: Disabled debug logging due to GUI setting. Level 0.
17:01:34  22.310595 T:3023745584  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"

I tried to be very explicit and the steps are not difficult. Only logs created on a boot that results in black screen will be helpful.

How do I enable debug logging through SSH?

You’ll have to edit/create advancedsettings.xml for that.

I dont see anything strange… maybe it is CEC that is messing things up.

My OSMC go to black today too :frowning:

I’m reinstalling now :cry:

I cannot reinstall as I have many hours put into OSMC and RETROPIE. It would take long time to put back Everything i’ve done… so I am hoping someone can help me with this.

I have Retropie too, i put microsd in my PC, copy home/retropie and config.txt and reinstall :frowning:

Please provide the output of the following TV service commands, they will show what screen mode the Pi is running in and what modes the TV reports are available:

tvservice -s
tvservice -m CEA
tvservice -m DMT

Also, does your TV report that there is no signal (for example if you press the info button on your TV remote) or does it report a normal signal but the picture is just blank ?

BTW, Retropie makes some very invasive system changes including altering your apt source.list to add Raspbian sources on a Pi 2. This could easily cause serious problems when attempting to run an update.

Sorry, i install RetrOSMC