Black screen after upgrade

Continuing the discussion from OSMC's July update lands (a little late) with Kodi 15:

I upgraded OSMC via GUI. (Yes, it rebooted automatically). During the boot I can see the OSMC welcome screen but nothing from Kodi. Monitor is not off but shows only black. Here are the logs:
If I turn the monitor off and on it works again.

Is there any integrated backup mechanism what I can you now to restore the previous system? There is a base noise from the speakers since the upgrade so I would like to restore it.
I expected that if an update notification pops up into my face it’s only a minor update not something that can break my system and I didn’t think that I need to prepare another machine for debugging.

After that I installed the latest via command line ( sudo apt-get update && sudo apt-get dist-upgrade && reboot ).

Wait, so you are saying if you turn off the monitor and back on again you see Kodi OK ?

Yes, as you’re saying.

If you can see Kodi please check the resolution and refresh rate that is set to - if it is set to something unusual like 59Hz change it to 60Hz.

Since you can get into Kodi this way please use the log uploader in My OSMC to upload all logs so we have as much information as possible - preferably before changing any resolution settings. Thanks.

No picture which is fixed by turning the screen off and on is typically resolution / refresh rate timings that are a little bit out of the range that the screen can handle. You’d probably find on another screen it works ok, but changing the refresh rate and/or resolution should fix it.

Thanks for your answer.

The refresh rate was 60.

I changed the “hdmi_pixel_encoding” value from “default” to “RGB full” and it “solved” the problem.
(My OSMC -> Pi Config -> Display)

But after I changed back to Amber skin that I used originally the “hdmi_pixel_encoding” reset to “default” and the black screen issue came back. So the solution is not a real solution because and I want to use this skin as I did earlier.

In case of the the workaround (monitor off, on) the screen colors are strange. It’s greenish/yellowish.

What made you think to try hdmi_pixel_encoding ? That seems like an odd thing to try unless you have seen it suggested somewhere…

Changing skins will not change config.txt settings - are you sure your config.txt setting was saved in the first place ? There may be a bug in the Pi config module (we have received other reports) where it can crash without saving the changes so I would check /boot/config.txt to make sure the changes were written. Also keep in mind all config.txt changes don’t take effect until a reboot.

What kind of monitor is it ? HDMI or Composite ? Getting the wrong colours is not something I would normally expect from HDMI but can happen with Composite.

What resolution are you running in and have you tried switching to a different resolution ? Unfortuantely your logs no longer seem to be on the paste service so I can’t check in those.

It was a brute force way. I changed every monitor related settings.

It’s an HDMI monitor. It’s good to know these settings are stored in /boot/config.txt.

What I did…

  • Skin: OSMC
  • hdmi_pixel_encoding=default (in the GUI)
  • Change “hdmi_pixel_encoding” to “RGB Full”
  • Perform reboot
  • No black screen :slight_smile:
  • hdmi_pixel_encoding=“RGB Full” (in the gui)


  • Skin: OSMC
  • hdmi_pixel_encoding=“RGB Full”
  • Change “hdmi_pixel_encoding” to “default”
  • Perform reboot
  • Black screen :frowning:
  • hdmi_pixel_encoding=“default” (in the gui)


  • Skin: OSMC
  • hdmi_pixel_encoding=“default”
  • Change “hdmi_pixel_encoding” to “full RGB”
  • Maybe there was a reboot here, I cannot remember
  • Change Skin to “Amber”
  • Perform reboot
  • Black screen :frowning:
  • Change skin from “Amber” to “OSMC”
  • Check “hdmi_pixel_encoding” value (in gui)
    3.Expected Behavior)
  • hdmi_pixel_encoding=“RGB full”
    3.Actual Behavior)
  • hdmi_pixel_encoding=“default”

I re-posted the logs:

I cannot provide you more information because I reinstalled the whole system to the previous version.
I made a full “disk” image saving of the wrong system, but currently I cannot restore it and test config saving because now I need a working system continuously.