Black screen at 1920p @ 30 hz (Solved)

Hello im trying to setup my Pi 3b+ since 2 months. It already worked, bevore i unplugged the HDMI cable. Since that it doesn’t work anymore and i tried to fix it since 2 monts. Can anyone help me please?
I saw that the Pi 3b+ supports 1920@30hz. My old configuration was 1920@25 but that also doesn’t work anymore.

Debug Logs:

thank you alot.

The screen doesn’t display anything? The changes you made to config.txt, was this before or after the problem. Have you tried a different hdmi cable and or differ TV? Is there a reason why your forcing hotplug and using CEA mode 34 instead of 16, or just setting it in Kodi as would be most common?

Yes my Tv and my Computer Display does not display anything. i just installed a new osmc system and nothing worked, thats why i made changed in the config.txt file after this. I just setup hotplug because in some forums they recommend it and i used CEA 34 because i saw that the Pi3b+ does not support 1920p@60 (CEA 16) only 1920@30 (CEA34) or am i wrong?

I just noticed that everything works on low resolution…

My Pi 3B+ manages 1080p/60Hz just fine. Whether the display handles it okay is another question, of course.

Have you tried another hdmi cable? All the RPi models support CEA 16, and that is actually the mode they are most commonly run at. Furthermore your display is advertising support for it as well…

====================== Pi CEA =================== su34JRse
Group CEA has 16 modes:
           mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
           mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive 
           mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive 
           mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive 
           mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced 
           mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced 
           mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 
           mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive 
           mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive 
           mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive 
           mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced 
           mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced 
           mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive 
           mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive 
           mode 33: 1920x1080 @ 25Hz 16:9, clock:74MHz progressive 
  (prefer) mode 34: 1920x1080 @ 30Hz 16:9, clock:74MHz progressive 

---------------------- Pi CEA END --------------- su34JRse

I’m assuming that log was generated connected to a TV. It is possible your monitor does not support that, or any, CEA mode. Hard to say without know what the monitor is or logs to see what it is reporting.

My HDMI Cable just arrived and everything worked… i was rly sure that the cable is fine because it always worked on my pc… sorry guys have a nice day and thank you alot:)