Black screen on composite output after update

Hi, I’ve been using OSMC for a few years now on a Pi 3B, connected via composite to a CRT TV.
After a recent update (I updated this past weekend - not sure when the update was released, but it was sometime in the latter half of 2021) I am no longer seeing the Kodi interface on the composite output. I see the boot splash screen, but after that just get a black screen.

If I connect a display to the HDMI port I see the OSMC/Kodi UI just fine.

The device is still discoverable on my network, and I can connect via ssh, access the Web interface and even AirPlay to it from my phone. I’ve done a clean install using the latest image and get the same result.

Here are the logs I’ve grabbed from the system:

I tried to check tvservice but got the following message:

osmc@osmc:~$ tvservice
tvservice is not supported when using the vc4-kms-v3d driver.
Similar features are available with standard linux tools
such as modetest from libdrm-tests.

This thread seems somewhat related but not exactly the same problem as I’m having RPi2 composite failure - #8 by roberto1

Anything I can check/change? I’ve tried /boot/config.txt options but no success so far.