Black screen on every first start


I’ve installed OSMC on Raspberry Pi 1. I was using Raspian. OSMC looks faster and have a nicer default interface. My biggest problem with OSMC is black screen on first start.

I almost gave up when installing. Because monitor didn’t come up no matter how many times I tried. I gave a 15 minutes break and glad I did. When I returned screen was up. I’ve installed/configured my Pi without any problem. And restarted successfully. After I was done I moved my Pi to it’s place. But again black screen. I’ve waited 10 minutes with no luck. I was able to connect with SSH and with my Kodi Android remote app. So I restarted. And there it is, in just under 2 minutes my monitor was up. I’ve tried a few more times and it’s always the same. If I shutdown the device and start again screen doesn’t come up. If I restart it comes up just under 2 minutes.

As I said it’s a Raspberry 1 B+ model. I’ve never had any problem like this with Raspian. My monitor is 17" LG LCD.

What could be the problem?