Black screen on start up. fixed by reboot [Solved]

I have a pi 1 B based osmc set up just fine. except…

As its in a bedroom linked to tv, powerlines, xbox etc on the same 4 way gang, the lot is switched off when not in use.

When I switched it on, the tv, power line etc comes to life. I can see that the kodi has started up as the remote on the ipad is working. However the tv says no signal.

I then tell osmc/kodi to reboot via the ipad app and then osmc comes to life just fine.

Any ideas as to why I have to perform this reboot, or anyway to avoid it?

Try this

http://kodi.wiki/view/Raspberry_Pi_FAQ#TV_is_not_detected_unless_powered_on_first

THanks for the reply. that seems to be my issue.

is there another tutorial that actually explains what doing a sudo means? :slightly_smiling:

that wiki doesnt seem to have a full explanation and how to attached

Do I assume correctly you want to know what it means to use sudo? sudo is a command that allows the “normal” user to execute commands as super user (root) http://linux.about.com/od/commands/l/blcmdl8_sudo.htm

Maybe also check
Details how to access OSMC via command line locally or via ssh can be found here: https://osmc.tv/wiki/general/accessing-the-command-line/
Here is a cheatsheet for how to navigate in a linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems

Perfect. awesome help.

Exactly what I was needing.

thanks again.

sorry. more linux help needed.

ssh’s in ok using putty. ran the sudo command and created a edid.dat file in the root that I can see with the ls command.

i can change to the /boot directory using cd /boot and then a ls shows me loads of osmc files including config.txt.

so according to the other link i tried the linux command

cp edid.dat /boot

to copy the edid from root to the boot /but get

cannot create regular file. permission denied.

any tips. also, how do I edit the config.txt file in putty/linux?

sudo cp edid.dat /boot

rapid linux course here :slight_smile:

thanks yet again. Your help is very appreciated.

So managed to copy the edid.dat file to the /boot. ta.

Now looking at editing the config.txt file. google tells me to use

pico config.txt

it opens the file and I can make the changes. however, when I try and save, either as the same config,txt or as a new name I get permission denied.

tips please?

edit -

sudo pico config.txt

seems to work!

sudo is the answer to all my questions it seems - lol

Everything that you do on /boot you have to do as as superuser so using sudo.
So either sudo pico /boot/config.txt or sudo nano /boot/config.txt

If you do a ls -lah /boot you will see the owner and the permission of the files on /boot.
They all belong to root and are only writeable by the owner

1 Like

Don’t forget there is an option in My OSMC -> Pi config to capture and install an EDID file for you without doing all this manually…

There is… :flushed:

But I wouldn’t have had as much fun that way. lol

WOW LOL… I totally forgot about that…

Sorry!

BTW, is your actual problem now fixed? If yes please set the post to SOLVED

erm. dont know. Angelic child is watching Pinocchio just now (having been watching Disney all day) and I’ve not had the chance to reboot yet!

1 Like

All working great now.

Late to kodi and pi. Greatest tenner (second hand kit from an upgrader) I ever spent!