Black screen when running retrosmc from custom menu item or ssh

I’ve followed the installation instructions from the retrosmc github project page on 2022.03-1 osmc on an rpi 3.

The installation finished successfully and the launcher has been also installed. However the launcher is not available on the programs section in osmc. I have also created the custom menu item as described in the same link.

When running the retrosmc from the custom menu item or from ssh, I get a black screen (a dash appears in the upper left when run from ssh).

I see that emulationstation and processes running.
I see no error in /home/odms/.emulationstation/es_log.txt.

I reboot the rpi in order to get to working OSMC again.

Can you help out?

Which version of OSMC are you running?

osmc@aragorn:~$ grep Kodi .kodi/temp/kodi.log  | head -3
2022-05-01 21:59:44.658 T:431      INFO <general>: Starting Kodi (19.4). Platform: Linux ARM (Thumb) 32-bit
2022-05-01 21:59:44.658 T:431      INFO <general>: Using Release Kodi x32
2022-05-01 21:59:44.658 T:431      INFO <general>: Kodi compiled 2022-03-08 by GCC 8.3.0 for Linux ARM (Thumb) 32-bit version 5.10.78 (330318)
osmc@aragorn:~$ grep VERSION_ID /etc/os-release

Is there anything I can do or try out to get around this problem?

Unfortunately I don’t know much about RetroPie.

Is there any suggestion on which forum could I take this forward?

I’m understanding you are using mcobit installer, been ages since I looked at it, i don’t think it has been updated since v.17 was released.

Generally since I used the launcher in other bit’s i know that someties it’s a timing issue with Kodi closing and the other software starting, where the other software starts, but Kodi either doesn’t let go of the VT in time or not at all.

So this is just a guess: try put a sleep 12 between retrosmc’s closing of kodi and starting of emulationstation.

Yes it’s mcobit installer.

a sleep 12 between retrosmc’s closing of kodi and starting of emulationstation

Looking at retropie starting script it first starts retropie_watchdog, then emulationstation and at the end it stops kodi. So per your description, kodi should be closed first ?

I tried with increasing sleep to 12s at line 44, but it gave same result.

Sorry have to reserve some time to look at it to remember what was what, I remember there where “two files” involved. I might even image the pi3 and try it up. But first I have to start a real late dinner, had one of the start of the summer warmest days so far, and pressure of coming thunder and light showers. No one wanted to eat before the sun at leas stopped warming so much.

Hope to get back to you in 24hs.

No worries, I also troubleshoot it in my free time, which is limited :slight_smile:
Any help is appreciated, thanks!