Black screen with rpi3 when connected to TV via HDMI

I decided to give it a try to OSMC. I installed in a rpi and tested in a pc monitor and it looked ok. I have ssh access to it and everything seems fine.
I decided to plug it in with a TV via HDMI (first the TV was on and after that I switch on the rpi) but I’m getting a black screen:

That’s my config.txt
gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
gpu_mem_256=112
gpu_mem_512=144
sdtv_aspect=1

Logs are here:
https://paste.osmc.tv/salenenaji

Any help will be much appreciated.

I would suggest to try another HDMI cable and/or input on your TV.

Thx for the reply @darwindesign.

Did that already. Two different HDMI cables and two different HDMI inputs.
Funny thing is that in my pc monitor, with the same HDMI cable it works.

What else to check?

Is the TV your connecting it to able to receive the same 1080p 60hz single as the monitor your using? Maybe try setting it to 720P and see what happens.

Yes, TV should not be a problem. It’s perfectly capable of receiving FullHD@60 HZ.
Actually, before OSMC, I had raspbian running Kodi on the very same rpi without any issues

Did you try it without hdmi_safe=1 in your config.txt?

Actually, initially the config.txt file didn’t have that line. And it didn’t work.
I put it in, and still didn’t work.

Not sure what is happening here. As I said, with raspbian it was working using same TV, cables and power supply.

The difference seems to be here:
Monitor:
raspikodi: ~ # tvservice -s

state 0xa [HDMI CEA (31) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

TV:
raspikodi: ~ # tvservice -s

state 0xa [HDMI CEA (31) RGB lim 16:9], 1920x1080 @ 50.00Hz, progressive

maybe try adding this to config.txt

hdmi_group=1
hdmi_mode=16

If that doesn’t work try some other hdmi modes. The odd thing here is that mode 16 is what your logs show and that should be 1080p 60hz but for some reason your log shows…

Found (640x480@60.000000) at 16, setting to RES_DESKTOP at 16

Perhaps @grahamh might have an idea of what is going on.

Thx a lot @darwindesign. Tomorrow morning, I’ll try a fresh install and will come back to you.

That’s expected if only one mode (or none) is discovered. 16 doesn’t relate to the VIC.

Thx for the reply @grahamh.
In a freshly installed version, these are the logs:

https://paste.osmc.tv/huninekicu

and these, to confirm:
osmc@raspikodi:~$ tvservice -s
state 0xa [HDMI CEA (31) RGB lim 16:9], 1920x1080 @ 50.00Hz, progressive
osmc@raspikodi:~$ tvservice -l
1 attached device(s), display ID’s are :
Display Number 2, type HDMI 0

Any idea why I’m not getting any output on the TV?

Sadly, no. I can’t see anything odd on that log, but I don’t know a lot about RPis.

It’s is weird indeed. With Raspbian OS, there is absolutely no problem getting output on the very same TV with same HDMI cable, PSU and SD-card.

I just fired up a Pi and my config.txt is this:

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
decode_WVC1=0x160d684e
hdmi_pixel_encoding=1
  1. if you did set hdmi_group and _mode they aren’t in your log - SD card gone r/o?
  2. hdmi_pixel_encoding=1 is RGB limited which I think you are already outputting but it could be worth a try

That’s my config.txt right now:
gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
#gpu_mem_256=112
#gpu_mem_512=144
#sdtv_aspect=3
#sdtv_mode=2
hdmi_group=1
hdmi_mode=31
hdmi_pixel_encoding=1

and my logs:
https://paste.osmc.tv/upuxahuwap

All seems to be ok, but still no output :frowning:

This is the config from my Pi3B+ (you seem to have a Pi3B model since your ARM clock frequency in your logs is 1200 MHz instead of 1400 Mhz):

gpu_mem_1024=256  
hdmi_ignore_cec_init=1  
disable_overscan=1
start_x=1  
disable_splash=1
hdmi_pixel_encoding=2  
gpu_mem_256=112  
sdtv_aspect=1  
gpu_mem_512=144  
sdtv_mode=2  
max_usb_current=1

What TV brand and model you’re using?

For tests I would add the line

hdmi_force_hotplug=1

to your config.txt and reboot the pi. Is there any effect? Config parms for the Pi here: Video options in config.txt - Raspberry Pi Documentation

Thanks @JimKnopf for your reply. The TV is an old plasma Panasonic TX-P42G10E.

I’ve tried your setup and still doesn’t work. Same black screen.

Running out of patience :frowning:

Logs:
https://paste.osmc.tv/iqelugiyih

My TV is a plasma TV Panasonic TX-P42GTW60 … RGB pixel encoding should work in any case.
Perhaps, you try my config.txt as the logs show you don’t. But running out of ideas, now.

It’s pretty frustating man! Using your config it doesn’t work either.
What it puzzles me is that there are no issues with Raspbian OS.