Black screen

Can everyone with this issue please try setting their desktop to 1080p50 or something other than the resolution of the vids they are playing? For me, forcing a resolution change always works. Not a permanent solution but should restore some sanity.

1 Like

I can’t seem to change the res of the kodi interface. The settings are greyed out at 1080P 60Hz and says windowed for some reason.

EDIT: Changed frame rate to 24Hz after a reboot. Working for now until we can figure it out.

I have the GUI set at 1080p60 but all the files I am getting the black screen with are 2160p24 or 2160p60. So it is not a resolution issue. As I have reported in the other thread the files do sometimes play (4 successes out of 26 attempts!).

However I have just changed the refresh rate to 1080p24 and now the files are playing more often than not (but still often getting the black screen followed by ‘no signal’). So maybe a refresh rate issue rather than resolution?

If necessary, you can revert here: Video improvement details.

Sam

Just to let you know, since October update same thing here; Short Black screens will playing and also sometime my TV says “unsupported mode” and I have to restart the Vero 4k to have it work again.

If it helps I Have a Denon avr-x2300w and a Samsung un65es8000.

I will apply the hotfix for now.

Hi,
I’ve just found this thread, and I’m wondering if it’s the same issue as I’ve been experiencing.

I created a new thread yesterday (not knowing about the existing ones):

Notably the first time I had the issue was before the October update, but after installing a test build which includes various fixes which were incorporated into the October release.

Hello

I have the same problem as you with my VERO 4K : few seconds after begin of playing I lose picture and my TV let appear “not supported video format”.

I must reboot Vero 4K, and now more and more, I must do many times, to find a normal situation.

Do you have a solution ? Please give us information asap

This problem is appearred after the last update on October (I don’t received update since October), and now his appear at each try to play now.
Before I never met this kind of problem and nothing has change in my home theatre system.

Thank you a lot for your help

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

It should be fixed in the December update which will arrive shortly.

Cheers

Sam

Dear Sam
Dear All
All problems of black screen has disappeared with latest update from December.
Thank you a lot !
That is the efficiency !

Best regards

2 Likes

Glad to hear this. Thanks for confirming.

It’s the same problem here but december update do not fix it. :frowning:

1-2 seconde black screen when playing movie since october update

I activate debug log on january 6 at around 9h40, reproduce the bug with “A Simple Favor (2018).mkv” movie and desactivate the debug log.

Here’s the log:
https://paste.osmc.tv/utesefazij

Good for you. Congrats, @Tolosatof :smile:

Does this happen regularly?
Have you tried a different hdmi cable?

There seems to be some sort of addon that’s hitting the database and the OSD all the while. I don’t know if that’s related but perhaps you could try with any non-OSMC addons disabled.

I did not try with a different HDMI cable or disable the plugins because the problem really appeared with the October update and when I applied the hotfix to reverse to the older version, the problem stopped . But when I made the December update, the problem appeared again. It appears only few time in a movie.

I just try to disabled all plugin except OSMC… I’ll let you know.

It did not work, he just did it twice.

You should enable Adjust Refresh Rate.

I just enable it. Let see. Thanks!

Here’s the log just after the black screen and before I Enable Adjust Refresh Rate as suggested by sam_nazarko.

https://paste.osmc.tv/cijicocisu

Let see if it work.
Thanks