Black Steam Link stream on Pi 4

I recently upgraded my OSMC setup from a Pi 3+ to a Pi 4. Everything is smooth and works well with my 4K projector. (Thanks or all the hard work that goes into making this happen!)

Installing Steam Link via swetoast’s Steam Link Launcher worked well too… but once setup the video stream from the host Steam machine is pitch black. Steam Link’s detailed statistics indicated that the stream was definitely being received though, and the Steam host audio being audible on the client confirmed this.

At first I thought it was problem of client resolution, since the Steam Link client defaulted to the highest possible resolution (2160p) even if setting OSMC to 1080p. I dabbled in trying to limit the resolution of both Pi, Steam host, Steam client and the Steam stream itself to no avail. Tried hardware and software rendering etc.

Then I installed Raspbian Buster on another SD card and managed to stream 1080p over Steam Link perfectly fine with a system resolution of 2160p on that system, but only once I’d commented out dtoverlay=vc4-kms-v3d in its config.txt.

Now, as I’ve understood it OSMC/Kodi needs vc4-kms-v3d to run, but what puzzles me is that others have seemed to get OSMC (with Kodi 19). Have I missed something here?

You can set dtoverlay=vc4-fkms-v3d in config.txt.
With that Kodi/OSMC should in general work but you might have issues with acceleration and DRM at one point.

Doing so only results in the system never getting image nor accepting SSH connections. (Reverting back to dtoverlay=vc4-kms-v3d fixes that). SSH gets stuck forever on debug1: Sending env LANG:

debug1: Authentication succeeded (publickey).

Authenticated to osmc ([x.x.x.x]:22).

debug1: channel 0: new [client-session]

debug1: Requesting

debug1: Entering interactive session.

debug1: pledge: network

debug1: client_input_global_request: rtype want_reply 0

debug1: Remote: /home/osmc/.ssh/authorized_keys:1: key options: agent-forwarding port-forwarding pty user-rc x11-forwarding

debug1: Remote: /home/osmc/.ssh/authorized_keys:1: key options: agent-forwarding port-forwarding pty user-rc x11-forwarding

debug1: Sending environment.

debug1: Sending env LANG = sv_SE.UTF-8

That would be strange as it works here
Did you left the full line?

1 Like

I did not! dtoverlay=vc4-fkms-v3d,cma-512 did the trick! Thank you very much.

Correction: The config line indeed did the trick wrt making Steam Link streams working perfectly.

The problem now is that regular video files freezes OSMC. Need to get back with real logs ofc.