Blank screen after reboot on brand new Vero 4K+

I installed the plexkodiconnect addon, and after changing some of the settings, it said that kodi needed to be restarted. I powered it down through the menu, but after starting, it shows a brief osmc screen, and then goes blank, and the AVR reports ‘no signal.’ Help. I know nothing of kodi or programming, and it’s not been easy to get this going.

Turned out to be a bad HDMI cable (which happened to be the one that came with the unit). Switched it to a new Monoprice certified cable, and I’m back in business. I’ll be back with many more questions, as none of this is very intuitive for me, but I’ve got Plex working with my server, and got Atmos going, which was the whole reason for getting this.


If the HDMI cable worked on receipt, it’ll stay working on a reboot.

Did you change any resolution settings?


I think I did. I set it for 4K resolution. I wondered if that was the problem, but after changing the cable, it worked again. I’m way out of my element with this thing, and I consider myself fairly tech savvy. I’ll get there. Everything is working now. Thanks for the reply.

You should leave the GUI on 1080p and set “Adjust Refreshrate” to “Start/Stop”

1 Like


Sam, you were right. The cable shipped with the Vero is fine–I swapped it back. I assumed a bad cable when I was getting the blank screen–I apologize for disparaging your HDMI cble. All is working fine today.

Thanks again–Ta!

Glad to hear this. But if there was a problem with our cable I’d have gladly just sent you another