Blank screen doesn't work after April update

#1

Hello, has anyone noticed the blank screen function doesn’t work anymore since the April update?

I had set my to go blank after 1 min when paused so a static image doesn’t remain on the display very long. It now just goes dim not blank. It does go blank when no media is being played.

Rakesh.

#2

There is a setting in the screensaver settings “Use dim if paused during video playback”. Make sure it is not set, and whatever screensaver you have set (like “Black”) should kick in all the time.

#3

Confirmed its not set. Doesn’t work on both the veros I own.

Log uploaded: Https://paste.osmc.tv/eyiziqexeq

Please could you let me know what i am doing wrong or is it a bug. Works fine in menu screen as I said.

#4

According to the log, you definitely have “Black” set as the screensaver, with “Use dim…” not set, and it is definitely going straight to the “Dim” screensaver when paused. I don’t see that the “Black” screensaver ever gets triggered, though.

The only thing I can think of is to try to change the screensaver settings and see if something in the upgrade wasn’t carried over correctly.

First, enable the “Use dim…”, pause a video to see that it is dimming, then stop and change “Use dim…” back to disabled to see if that fixes it.

If that doesn’t work, change the screensaver to something other than either “Black” or “Dim”, save the changes, restart Kodi, then change the screensaver back to “Black”.

#5

Thanks, i gave that a go, didn’t work.

As it happening on both my devices, does that mean it’s just a bug? Although doesn’t appear anyone else is affected.

#6

Are you using the suspend mode?

Sam

#7

This might be a Kodi bug, but here’s a workaround:

  1. Change the screensaver to “Dim”.
  2. Click on “Settings” for the “Dim” screensaver.
  3. Change the level to “0%”.
  4. Click “OK”, and then test.

This should give you an almost completely black screen.

I have been told the GUI on Leia does not allow setting below 20% (which is way too bright on my system to really do any good for an extended pause). You can set it to 20% via the GUI, then edit the settings file to change it to 0:

/home/osmc/.kodi/userdata/addon_data/screensaver.xbmc.builtin.dim/settings.xml
#10

Is that the one in settings >system > power saving? If so no i am not.

Also I checked the one that is buried in the cec control and set it to ignore as it was set to suspend. However it had no effect.

#11

Awesome I will give this a go. Thank you.

#12

Hi, sorry, but I see no difference between 20% or 0% which is set via editing settings.xml
Putting 0% does not seem to work.

#13

Kodi devs may have hard-coded the 20% minimum in the source code. I don’t see how this benefits the user, as 20% on a bright HDR screen will still cause burn-in on an OLED.

Perhaps @sam_nazarko can modify the OSMC version of Kodi to remove this restriction.

1 Like
#14

Yeah burn-in is my concern.

#15

We can indeed change this.
Just remind me in comms so not forgotten.

Cheers

#16

Hello i just tested this in the May update. Seems it wasn’t fixed. Is that correct?

#17

I didn’t make any screensaver specific changes here.

#20

Hi Sam,

Just wondering if this is still in the roadmap to fix , it would be really handy for dim function to go below 20% as I have a couple of OLED’s .

#21

I wasn’t aware this was still an issue.

Will report upstream

Sam

#22

Sam are you able to provide a time line on when this will actually be fixed?

#23

This doesn’t seem to be an issue with OSMC but rather Kodi. I am not sure when it will be fixed

#24

ok thanks. getting more and more worried it will cause me a ruined oled if i am not careful.