Blank screen going (back) to KODI menu


I’m periodically getting a blank screen when starting KODI but mostly when ending a movie/series/youtube etc.
At that point nothing seems to work, using my remote control through CEC, but also the KODI app on my iPhone/iPad isn’t responding to starting a movie and by closing it … not even a restart command.
The only way to get display again is by restarting the mediacenter service.

This problem starting when I changed my AVR to an Onkyo TX-NR636, I’ve recently replaced it with an TX-NR646 which made the problems stay away for awhile, but since the upgrade to KODI 15.x I’ve seen these problems again.

No display at startup of KODI:
Working after a mediacenter service restart:
No display after stopping a random movie:
Working after a random movie:

One thing I’ve noticed from the debug logs is (no display):

16:21:36 3390.099365 T:1957253120  NOTICE: Found (1920x1080@60.000000) at 22, setting to RES_DESKTOP at 16
16:21:36 3390.099609 T:1957253120  NOTICE: Checking resolution 16
16:21:36 3390.112305 T:1957253120   DEBUG: EGL set HDMI mode (1,16)=0 off
16:21:36 3390.187012 T:1909453856   DEBUG: EGL tv_service_callback (1,2,0)
16:21:36 3390.193359 T:1909453856   DEBUG: EGL tv_service_callback (1,1,16)
16:21:37 3390.726562 T:1909453856   DEBUG: EGL tv_service_callback (2,1,16)

Versus (working display):

16:26:07 3660.758057 T:1957195776  NOTICE: Found (1920x1080@60.000000) at 22, setting to RES_DESKTOP at 16
16:26:07 3660.758057 T:1957195776  NOTICE: Checking resolution 16
16:26:07 3660.770264 T:1957195776   DEBUG: EGL set HDMI mode (1,16)=0 off
16:26:07 3660.844727 T:1909453856   DEBUG: EGL tv_service_callback (8,1,16)
16:26:07 3660.845947 T:1957195776   DEBUG: EGL set resolution 1920x1080 -> 1920x1080 @ 60.00 fps (1,16) flags:10010004 aspect:1.00

Hope somebody can point me to the right direction, maybe @popcornmix since he has fixed a lot of HDMI problems :neutral_face:

Disable CEC

Does this help?


Not really an option, since I use CEC for remote control.

Was not suggesting it as a solution, but to get some debugging ideas.

I just started the movie again … no response from any keypress from my remote through CEC.
So totally unresponsive atm … debug log attached and going for service restart again.

Will try right away!

I just changed SETTINGS - System - Input devices - Peripherals - CEC Adapter to disabled

Haven’t seen an issue as of yet … could be you hit the nail right there!

And after a few more tries … it did blank the display :frowning:

Can you ssh in and report output of

tvservice -s

in both the non-blank and blank cases.

In the menu:
state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

While playing a movie:
state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 59.94Hz, progressive

It is still the above at 59.94Hz, display plays the movie, but no remote control working anymore (no CEC still using the iPhone/iPad Kodi app, will restart the service again and will update when I get a blank screen.

Blank screen at the startup of a the movie, audio plays, but again remote control doesn’t work so restarting the service again:
state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 59.94Hz, progressive

Did you run the tvservice command when the display was blank? That’s what I want to see.

state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 59.94Hz, progressive

That is what it returns when the display is blank but the movie was still playing (audio only).

I just enabled CEC again, now when stopping the movie it went blank again:

state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

I just noticed when I did the ‘service mediacenter restart’ the GUI just came back and it restarted KODI.
Here is the kodi.old.log:

Can you try bypassing the Onkyo and connecting direct to TV?
I’d like to know if the problem requires the Onkyo to be present to fail.

I think I could try that, think I got a spare HDMI cable somewhere.

Haven’t seen a single blank screen, started the movie for about 20 times I think.

Reconnected it back through the AVR again, 3th time … blank screen on movie start.

What to do now?

Switch to another HDMI source and back again doesn’t solve it either…

I have an Onkyo TX-NR609 and don’t have this issue.
Can you try adding hdmi_force_hotplug=1 to config.txt setting?

Looks good, restarted the movie 10 times and haven’t seen a blank screen as of yet :smile:

Interesting. That suggests onkyo is deasserting/asserting hotplug when we change hdmi mode.
That’s used to indicate display is unplugged/powered off and I’ve never seen this occur when we change hdmi mode.

It might be worth checking if you can upgrade the firmware of the onkyo (mine has a network socket for firmware updates) as it would be interesting to know if there is a change in behaviour.

If I could reproduce this I could probably work around it. I’ll have a think about whether I could fake this somehow for debugging it.

hdmi_force_hotplug=1 should be a safe workaround for you though.

When I ran ‘tvservice -M’ and started the movie, it showed a unplug/plug.
I thought that was normal when changing modes :confused:

My firmware is up-to-date that was the first thing I tried :smile: