Blank screen with UHD MKV since update

Hi , since updating to 2021.08-1 I have lost the ability to play UHD MKV files, the system displays a blank screen but audio continues to play. Most times I have to force a reboot in order to be able to get back to the OSMC menu.

I have attached a link to my log files.


Please turn on debug logging and upload logs again.

And can you check playing with audio passthrough turned off?

Can also confirm that turning off audio pass through didn’t seem to change anything. Also, I cannot change the System Resolution above 1080p as I again get a blank screen.

Is that an Epson beamer behind the Sony AVR? What brand/model is this TV/beamer device? Could you try for tests what happens if you direct connect this device to the Vero?
Any HDMI cable issue possible causing such problems with this bandwidth?

I think the problem is just the @mostlyfurious has set output to RGB. If there’s no overriding reason for this, turn off Force RGB output and re-boot.

Let us know how that goes.

Thanks all, I turned off Force RBG and that worked for a short time but then I ran into the same issue. I then swapped out the HDMI cable and guess what? It seems to be working. Apologies for the wild goose chase, must be a coincidence that the cable crapped out around the time I updated OSMC.

1 Like

No worries. You exposed a bug which has now been fixed. It wasn’t just the cable.

Hi. I’m having black screen issues to, so I have a question:
is the black screen total or if you use the remote contoller you can see OSD?