Blank screen

Occasionally, my vero will.suddenly just go to a blank screen. It’s happened a few times before but usually unplugging at the mains then reconnecting the power usually sorts this bit it’s happened again twice this evening and disconnecting reconnecting the power has not solved the issue for me.

I get to the master user screen and hit select and the Vero proceeds to rescan for any new media and whilst doing this it suddenly just goes blank without completing the rescan (for new media)

Help please …

If you’re not familiar with the command line etc you’d probably be best reinstalling OSMC.


Thanks, and how do I do this ? Reinstall OSCM if the screen keeps blanking out ?

Usually when it happens repowering up solves it for weeks …


When you say “blank screen” do you mean that the Vero stops sending out a picture, it sends out a signal but it is just black, or that your skin is displaying incorrectly? Does this only happen when you are doing something specific like switching profiles or random? If we had a more complete picture of exactly what is happening, preferably with debug logs covering the time frame the issue manifests, then that may lead to a solution without having to perform a reinstall.

Ok, so here’s the latest …

I’ve just repowered up …I get the log in screen, I select master user …

The Vero then goes on to scan for new files and today completes that process, (last night it got to 20% then blank screen/switch off)) and I think YES !! It’s back !!!

Then it completely blacks out, no skin … It appears it’s switched itself off as no button press brings anything at all back on screen …

As I said earlier, it’s done this on a few occasions before but a repower usually solves it for weeks …

If your still unclear of what is happening I will video it …

Thanks in advance :+1:

I would recommend disabling the auto library scan and see if the issue goes away.

Hi and thanks for the suggestion but I don’t think it’s anything to do with auto library update.

It’s not an issue that usually happens on start up or restart.

It’s now started up ok :+1: and will now probably run for a good few weeks before whatever it is strikes again.

And that is when the screen just goes blank and no button will bring back anything on screen so I’m guessing it’s powered down and that’s when I’ve got to unplug and restart. And as has happened this weekend, whatever caused the issue occured again whilst restarting on those 1st few attempts.

We’ve seen several people with similar problems, and turning off the auto library update has fixed it.

1 Like

Ok thanks.

Bit strange how that can cause the
Blank screen/power down when the unit is never switched off - unless the unit does the blank screen/power down thing but I will try turning the library auto update off …