Blu-ray folder playback problem

Hi there.

I’ve been having some trouble trying to play some Blu-ray folders from my Vero 4k running OSMC. Some would play, some would not. And what is more intriguing is that my other box running CoreELEC (a TX-3 mini) runs all my Blu-ray folders without a problem (other than some hanging, but at least it starts playing all contents, differently from my Vero 4k).

Here is the log:

Any idea why it works in CoreELEC and not on OSMC? I’m currently on OSMC last version, I guess (2018.08-2).

Looks like your NAS isn’t allowing the Vero to connect:

23:03:15.196 T:3640652528   ERROR: CBlurayDirectory::InitializeBluray - failed to open nfs://

Make sure your NAS allows the IP of the Vero to connect. What do you get if you try:

showmount -a

from a command line on the Vero?

I just noticed in your logs that playing a mkv from the same server seems to work, so I’d suggest that you give us full debug logs. You are running a Beta version of Kodi, so you do know that there may(will) be bugs.

Isn’t this the full debug? I enabled the all-something option prior to uploading the log.

My version of CoreELEC is using Kodi 18.0-BETA 2 Git: 18.0b2-Leia, which version is OSMC currently using?

You have to enable debug logging, reboot, reproduce the problem and then supply the logs.

You are running:

23:46:08.360 T:4073181792  NOTICE: Starting Kodi (18.0-BETA3). Platform: Linux ARM (Thumb) 32-bit
23:46:08.360 T:4073181792  NOTICE: Using Release Kodi x32 build (version for Vero)
23:46:08.360 T:4073181792  NOTICE: Kodi compiled Sep 15 2018 by GCC 6.3.0 for Linux ARM (Thumb) 32-bit version 4.9.30 (264478)
23:46:08.360 T:4073181792  NOTICE: Running on Open Source Media Center 2018.08-2, kernel: Linux ARM 32-bit version 3.14.29-119-osmc

Well generally OSMC runs v17 but from your log it seems you joined the testing thread NOTICE: Starting Kodi (18.0-BETA3)

Can you play the files from local storage?

When I enabled it debug info appeared on the screen, so I thought that was not the option. I hope the log is OK now:

I tried playing a bunch of movies, some worked and some didn’t, all in the same NAS folder, some were .mkv and others were Blu-ray folders. All movies are working on another Kodi running CoreELEC, as mentioned above.

Yeah, I remembered I enabled the unstable version trying to fix the problem (so I could install libbluray1, or something like that, if I remember correctly). No luck, though.

Could try later, but I think I found the problem:

DEBUG: CBlurayCallback::Logger - index_parse.c:187: index.bdmv failed signature match: expected INDX0100 got INDX0300

It appears I don’t have the latest libbluray, shouldn’t it be in my version (Kodi 18.0-beta3)? The problem seems to be with UHD discs, and that’s what this signature match error implies, from what I’ve read.