Blu-ray ISO playback issue

I have an issue with the with Blu-ray ISO playback because I cannot playback about half of my collection. Some ISOs working perfectly but others not. Unfortunately I cannot figure out the root of the problem. Here is a piece of the Kodi log when tried to start play a title which is not work:

13:18:38 125.592613 T:1958310448  NOTICE: DVDPlayer: Opening: /media/DISK06/Blu-Ray/Blade Runner (1982) 30th Anniversary Collectors Edition D1 BD50.iso
13:18:38 125.592690 T:1958310448 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13:18:38 125.592995 T:1752237088  NOTICE: Thread DVDPlayer start, auto delete: false
13:18:38 125.595581 T:1752237088  NOTICE: Creating InputStream
13:18:38 125.668686 T:1752237088   ERROR: Error on dvdnav_open
13:18:38 125.668823 T:1752237088   ERROR: CDVDPlayer::OpenInputStream - error opening [/media/DISK06/Blu-Ray/Blade Runner (1982) 30th Anniversary Collectors Edition D1 BD50.iso]
13:18:38 125.668892 T:1752237088  NOTICE: CDVDPlayer::OnExit()
13:18:38 125.669464 T:1958310448   ERROR: Playlist Player: skipping unplayable item: 0, path [/media/DISK06/Blu-Ray/Blade Runner (1982) 30th Anniversary Collectors Edition D1 BD50.iso]
13:18:38 125.669899 T:1752237088  NOTICE: Thread BackgroundLoader start, auto delete: false
13:18:38 125.679642 T:1958310448  NOTICE: CDVDPlayer::CloseFile()
13:18:38 125.679810 T:1958310448  NOTICE: DVDPlayer: waiting for threads to exit
13:18:38 125.679878 T:1958310448  NOTICE: DVDPlayer: finished waiting
13:18:38 125.679985 T:1958310448  NOTICE: CDVDPlayer::CloseFile()
13:18:38 125.680168 T:1958310448  NOTICE: DVDPlayer: waiting for threads to exit
13:18:38 125.680237 T:1958310448  NOTICE: DVDPlayer: finished waiting

Anyway I can playback these ISOs with my PCH A400 and an Blu-ray player also.

Has anybody any idea how I can playback this kind of ISOs?

Are you able to use a BluRay ISO editing tool to remove the main feature and produce a small sample file that shows the problem?

Yes, I can. So I made a modificated ISO wherein I replaced the main title to a menu piece. I tested with A400 and that is work with it. The size around 1.5 GB, how can I pass to you?

Google drive or dropbox should handle it.

OK. I sent the Dropbox link via message.

I’ve got your sample file.

00f11b8ecc1b9a7f755ef21353596d84  /home/dc4/mnt/Images/BDsample.iso

But it won’t play with kodi on Ubuntu, vlc or mplayer. Have you removed the encryption when ripping it? Kodi doesn’t support encrypted BluRay ISOs. Tools like AnyDVD and DVDFab can remove encryption. makemkv is another option for ripping BluRay files losslessly.

So, I am more or less sure the BD have no AACS encryption… :smile: (I did not find any tool to check this)

I checked the BD ISO content with VLC and it is can play the main feature (0020.m2ts) both from the original and the modified image. But VLC cannot play the ISO itself and I have no experience in this…

Just in case, I created a new ISO with DVDFab copy function from the modified image (AACS removing option turned ON (as always)). I tested again with VLC:

  • Play ISO: VLC freeze
  • Mounted ISO: 0020.m2ts: plays fine.
  • RPi2 Kodi: ISO plays fine… Ooopsss…
    I shaered this second image with you also.

As I known both image have no AACS encoding, so what could be the difference? Why the first IOS do not work with Kodi but the second ISO is yes?

Added: I tested the DVDFab copy with the original BD and the new ISO is also worked on Kodi… Strange…

I can’t say what is wrong with the broken ISO file.
Even mounting the ISO file and then trying to play one of the m2ts files fails with all players I own (I get a single frame of video then nothing, but I hear audio).

So this isn’t a Kodi / Pi playback issue, it’s a ripping ISO issue, but afraid I don’t know what the solution is.

Sorry for any inconvenience but that is what you should see. As I mention earlier I replaced the main feature with an element from the menu… So if you can play the 0020.m2ts (which is only a static picture and a short music) is great, but why Kodi cant play?

Okay, I hadn’t realised the video files are dummy.
It does seem that all versions of kodi behave the same (e.g. kodi on Ubuntu fails the same way),
so it may be best to post in general kodi forum and see if any of the devs have suggestions.