Blue artifacts in dark scenes

For some reason I seem to get blue artifacts in dark scenes on videos. I know its not the video as when its played back on a PC its fine.
The raspberry pi is plugged in to a receiver and is doing DTS passthrough but i wouldn’t have thought this to be the issue. As i said, its only in dark scenes,
The Pi is playing the film direct, no transcoding going on anywhere. Any clues as to whats causing this?

I would try to use another HDMI cable, and test without the receiver…

if still not fixet, please add picture/photo of the artifacts.


A photo or video may help us understand exactly what the problem looks like.
Can you connect Pi directly to TV (without receiver) and report if problem still occurs?
Can you try adding config_hdmi_boost=7 to config.txt settings.

Sorry I realise i didn’t reply to this previously. I will try a new HDMI lead in the next few days and post some screenshots if the issue persists.


Old thread I know but did never get the issue resolved

Here is a screenshot showing the issue:

Confirmed not the HDMI lead
Confirmed not the media file
Confirmed not the Pi as have tried with a new Pi

My thinking it is something to do with the Onkyio Receiver that the Pi is plugged in to. However I have tried all HDMI inputs on the receiver and still have the issue. Do not get the artifacts on other HDMI sources.

Any suggestions on things to try?

Also, does not happen in all dark scenes or for the entirety of the dark scene. Seems to be very random

Running latest OSMC on fresh build


I think we need more details on your setup, for video.

How have you set adjust display refresh rate?

Could you please on your video setup. under: settings, player?

Thanks Tom.

Did you test when removing the Onkyo and plugging direct to the TV?

yes no issue there

Will get this for you next time I’m back.

I believe everything is default apart from screen resolution which I changed from “desktop” to “1080p”

You’ve most likely got bad capacitors on the Onkyo video/HDMI board. I had one a couple? Maybe more , years ago. Replacing the capacitors wasn’t easy but did fix the issue.

EDIT: The blue dot issue required a new HDMI board which was done under warranty, I later had HDMI dropouts that was fixed by capacitors.

Did you try config_hdmi_boost=7? You can go up to 11 if 7 doesn’t help.

@popcornmix I’ll give that a try - which file do I set that in?

EDIT: can you explain what that setting does?

@Dilligaf I don’t think it would be that, I have 5 other devices connected via HDMI neither of which have the issue. I have also tried the Pi in all HDMI ports but the issue is still present. Why would it not be present on the other devices but only on the Pi if it was the HDMI board?


The easiest to add popcornmix’s suggestion, is probably via the command line

sudo nano /boot/config.txt

add the line:


ctrx-x to exit, yes to save.

sudo reboot 0

Thanks Tom.

This seems to have done the trick! Excellent

Only tried a few files but fingers crossed!

What exactly does this do, I’m assuming boost the output power on the HDMI port?

Did you even read the provided link?!


Configures the signal strength of the HDMI interface. The default value is 0 and the maximum is 11.

The default value for the original Model B and A is 2. The default value for the Model B+ and all later models is 5.

If you are seeing HDMI issues (speckling, interference) then try 7. Very long HDMI cables may need up to 11, but values this high should not be used unless absolutely necessary.

Yes i did read the link. It doesn’t say how it boosts the signal strength…

It also doesn’t say how this helps solve the issue.

Configures signal strength of HDMI output.

Seems pretty straight forward. Unless you wish to consult some electrical engineers on the specifics.

It probably is offsetting loss of signal due to a cheap or excessively long HDMI cable feeding the TV or signal strength lost in the onkyo.

Increasing the drive strength means that the output voltage is increased.

Raspberry Pi have to meet certain EMC requirements, and this means tests are done in controlled conditions. I suspect the boost figures are relative to the tolerances of each model.

There is lower tolerance with an increase in drive strength, and a potential for more interference. Sometimes, these changes will be out of compliance. But you made these changes, not RPF.