Blue-Ray discs doesnt play anymore?

I dont know when this started, but sometime during all the latest updates.

Blue-Ray rips where the main folder contains folders called “BDMV” and “Certificate” doesnt play anymore.
Kodi sometimes says something along the lines of “it didnt play - check the logs”

An example is folder:
Dolby Atmos Demonstration Disc 2014 1080p Blu-ray AVC TrueHD 7.1 Atmos

Here the file 00020.m2ts is the Atmos demo in the forest “This is Dolby Atmos”.

From when I got the Vero 4k (March 5, 2018) up until recently these all played fine.
In fact it was one of the first things I tried since i mainly got the Vero for Atmos and passthrough sound.

I also have a rip of Blindness in BlueRay with the same folder structure and this also played fine before.

This is the most intereseting part of the log file:
20:47:57.877 T:4075696720 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIA LIZED
20:47:57.878 T:3719295744 NOTICE: Creating InputStream
20:47:57.890 T:3719295744 ERROR: Unable to load, reason: libblu cannot open shared object file: No such file or directory
20:47:57.890 T:3719295744 ERROR: CVideoPlayer::OpenInputStream - error opening [smb://xx/xx/2016 DOLBY ATMOS DEMO DISC/BDMV/index.bdmv]
20:47:57.890 T:3719295744 NOTICE: CVideoPlayer::OnExit()
20:47:57.890 T:4075696720 ERROR: Playlist Player: skipping unplayable item: 0, path [smb://xx/xx/2016 DOLBY ATMOS DEMO DISC/BDMV/index.bdmv]
20:47:57.896 T:4075696720 NOTICE: CVideoPlayer::CloseFile()

I tried going back all the way to 69 but it didnt help :no_mouth: but now im on 78.

So did we loose the Blueray-library on the road? :thinking:

How can I re-install libbluray?

Need to see full debug logs. It is not even clear what version of OSMC you’re running

Logs sent in pm. I say at the end of my message that im on 78 and tried going back many versions. I think i screwed something up bc this definately worked beautifully before.

Please put your logs in this post. Doing so by PM limits the number of eyes significantly

78 is just kernel version, not Kodi version


One of them starts here:

Reinstalling libbluray1 helped so I can now get the meny or use a simplified meny.

But I want to know howcome this just disapeared for me and also is this the latest version and the one I should use?

I ran:
sudo apt-get update
sudo apt-get install libbluray1

I’d recommend not installing libbluray1 from Debian repositories as you have done. There should be an armv7-libbluray-osmc installed already.


I need some more help her as to what to do to fix all this.

Looks like an easy fix.

23:27:05.901 T:3361313536 ERROR: Unable to load, reason: cannot open shared object file: No such file or directory
23:27:05.901 T:3361313536 DEBUG: Dll was not found in path

What’s the output of ls /usr/osmc/lib | grep libbluray

I dont know if I changed anything now after I installed the Debian libs.

The command now gives this:

So what is going on?

Should i have another pointer towards the .2-version or should I somehow add that “” into the bunch somehow.

I need help.

I’ll follow up on this shortly



  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


Hey Sam,

it’s exactly the same for me, same error, same files in /usr/osmc/lib
I am already on “stretch-devel main”, always running the latest version.
“apt-get dist-upgrade” just got some timezone related stuff.
And “armv7-libbluray-osmc is already the newest version (1.1.0-1).”
I never tried to downgrade or anything.

Best regards,

When did you last update?

5 minutes ago (I’m on the german mirror though).

I’ll take a look shortly. It should be simple enough to get resolved.

There was a problem building Kodi for Vero 4K due to a new patch that was causing errors. I have fixed this patch and triggered a new build.

This is now ready and following the instructions above should allow you to test the fixes for Blu-ray support.

Thanks for your patience


Looks good on most parts, play Mainmovie and show playlists works, show menu doesn’t, it just returns to kodi after a few seconds.
Not sure what kind of menu my test-disc has, there is a jar file in jar folder.
Will check again tonight and post a debug log.