Bluetooth a2dp no Bluetooth Player

Hello there,

I reactivated an old project and tried to use the bluetooth function of osmc.
I am running the latest OSMC 18.5 on Raspberry Pi 3 with installed a2dp-app-osmc.

So far it worked to connect and play music from my android phone through the pulseaudio sink since activated in kodi settings. I am using the onboard bluetooth device.

My Problem is now, that the btplayer app is not appearing and no controls in OSMC or artist/track infos are visible. If i try to play music from the usb or youtube while playing from my phone via bluetooth it plays at the same time simultanously.

Does anybody know this kind of issue? Is there any known solution?

Was discussed in the a2dp thread a while ago

My recommendation for the time being is Yatse (if you have an Android phone)

1 Like

it’s a pity, and yatse is not exactly doing what I am looking for.

But thank you for your response.

I hope in the future there will be a btplayer implemented in osmc.

What are you looking for that Yatse is not doing?

If I get it right: Yatse uses the http source from kodi for remote control.

I am looking for streaming music via deezer or spotify on my smartphone and using my osmc device as “bluetooth speaker”. This works so far.

But I would like to have a visible interface for bluetooth streaming and avrcp controls on my osmc device.

Yatse (the paid version) also allows streaming for certain services

1 Like

Oh okay. Thanks!