Bluetooth and Wlan at the same time

#1

Dear all,
after some time, i get nearly everything running. I have the latest osmc running on a raspberry. I want to connect my samsung soundbar via bluetooth to kodi and my kodi is connected via wlan to my nfs server. the bluetooth connection is now working, i have to reconnect always after some time but i dont know how to improve it.
BUT the really strange thing is, after arround 6 seconds of streaming a movie with bluetooth activated and used my video stream hangs up. At first i didnt know why, but it seems like my wlan interface hangs up. i cant connect to via ssh anymore and after one click kodi is also freezing.
I remember during my research for bluetooth i have read something about problems using wlan adn bluetooth at the same time, but i dont remember anymore where and i dont find it at all.

Could somebody help me again?

Best regards,
Michael

#2

i disabled in the meanwhile with

dtoverlay=pi3-disable-bt
in file
sudo nano /boot/config.txt

and installed a d-link dbt-120 bluetooth usb stick.

But i have exaclty the same behaviour.

#3

Are you using a 2.4Ghz WiFi network? There might not be much that can be done about this.

Sam

#4

Is your power supply up for the job?

#5

hello,
i am using the onboard wlan of raspberry 3. when you tell me a way to find it out, than i can inform you in detail :slight_smile: but what do you mean? Is this a normal “problem”?

#6

Install wavemon sudo apt-get install wavemon and that will tell you if you use 2.4Ghz or 5Ghz

#7

mhmm, it was delivered with the raspberry. the data is:
5V with 3.0A. can i find out somehow that the power supply failed?

#8

Both Bluetooth and Wifi (2.4 Ghz) operate in similar frequencies which can cause interference

#9

This sounds good (by the read of it). To find out if the power supply is the issue you would need to measure if you get stable 5V out of it even under stress. But let’s assume it is fine then your problem might be the interference mentioned above. If you have a 5Ghz WLAN available you could try that.

#10

ok, the internal wifi uses 2.4ghz and an external usb wlan adapter from edimax also uses 2.4 ghz. i have at first to find out if i can switch one of them. i will try and come back.
thank you for the great support until now.
Michael

#11

Can you try that adapter with either a USB cable or USB Hub to just create some distance between the WLAN and the bluettoth?

#12

this is also a very good idea, because i have some problems with activating 5ghz onboard. somewho osmc dont want to connect to a 5g network i have created with my fritzbox. there is only a information box popping up with “connection failed”

#13

hah, it helped. i took a 5 m extension for usb and the external antenna was outside the room. so it seems that this is really the problem. either i find a way to use 5g on the osmc onboard or i find an appropriate lenght of cable (i set up everything above a beamer, and dont want to have to much cable there).
Ok, thank you for your support.

#14

Are you having a Model B+?
Can you see the 5Ghz network when you scan?
Does the 5GHz network has a own SSID?

#15

i think i have a B+. but i see definitivly the 5Ghz network when i scan. i have enabled it, and added a “5G” to the name. so now i see both the 2.4 and the 5 one. Yes, it has an own ssid. When i click on connect, there is a message “please disconnect the other” i disconnect the actual one and click than connect. and now it want to have the password but than there is only in the upper right an information logo with the message “connection failed”

#16

i see only 3 “balls” in the signal strength (two blue one and one white one) perhaps the signal strength is too less. 2.4 was even better arround 5 balls.

#18

Well 5Ghz is surely allways more weak for two reasons:

  1. It has lower output power
  2. It’s worse in penetrating through objects

But it should still be possible to connect. Maybe try from the command line (search here on the forum there are many wifi troubleshooting threads)

#20

by the way, which tool is osmc using for the network management? i dont find a interfaces file, or a wpa-supplicance file.

#21

ConnMan. We do use wpa supplicant for now, but will move over to iwd

#22

It’s connman. As written just search the forum. But basically start connmanctl on the command line and then in connman these commands with enter after each.
agent on, enable wifi, scan wifi, services, connect <THE WIFI you want to connect to from services output> it will then ask you for password.