Bluetooth Audio on Raspberry Pi Updated fixes?

#1

Hi I know there’s a few old threads but since it’s been a long time since anyone replied to those I thought I might start a new one.

I’m able to pair my bluetooth speaker on my laptop, phone, etc so I know it works.

From the KODI interface , getting Connection to XXX Falied
When I SSH into the PI, and try the bluetoothctl commands:
power on
agent on
default-agent
discoverable on
scan on
pair
–>Successful
trust
connect
Failed to connect: org.bluez.Error.Failed

Then I typed sudo systemctl status bluetooth and got

bluetooth.service - Bluetooth service

Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)

Drop-In: /etc/systemd/system/bluetooth.service.d

└─local.conf

Active: active (running) since Sun 2019-03-17 22:08:16 EDT; 22min ago

Docs: man:bluetoothd(8)

Main PID: 490 (bluetoothd)

Status: “Running”

CGroup: /system.slice/bluetooth.service

└─490 /usr/libexec/bluetooth/bluetoothd

Mar 17 22:08:16 osmc bluetoothd[490]: Failed to obtain handles for “Service Changed” characteristic

Mar 17 22:15:02 osmc bluetoothd[490]: a2dp-sink profile connect failed for FC:58:FA:7A:07:55: Protocol not available

Mar 17 22:16:26 osmc bluetoothd[490]: a2dp-sink profile connect failed for FC:58:FA:7A:07:55: Protocol not available

Mar 17 22:16:36 osmc bluetoothd[490]: a2dp-sink profile connect failed for 00:58:75:00:26:B6: Protocol not available

Mar 17 22:17:29 osmc bluetoothd[490]: a2dp-sink profile connect failed for 00:58:75:00:26:B6: Protocol not available

Mar 17 22:18:44 osmc bluetoothd[490]: a2dp-sink profile connect failed for 00:58:75:00:26:B6: Protocol not available

Mar 17 22:26:59 osmc bluetoothd[490]: a2dp-sink profile connect failed for 00:58:75:00:26:B6: Protocol not available

Mar 17 22:27:24 osmc bluetoothd[490]: a2dp-sink profile connect failed for 00:58:75:00:26:B6: Protocol not available

Mar 17 22:30:09 osmc bluetoothd[490]: a2dp-sink profile connect failed for FC:58:FA:7A:07:55: Protocol not available

Just wondering if there’s been any updates for the past few months or any work arounds? Thanks!!!

0 Likes

#2

Have you installed a2dp package?

0 Likes

#3

Yes I’ve installed it. BTW I’m not using a dongle, just using the bluetooth off of the Pi board. Is that even possible?

0 Likes

#4

Yes with the latest version that is possible.

Please provide logs via grab-logs -A and share URL and let us know the make and model of the speaker.

0 Likes

#5

Thanks, here you go:https://paste.osmc.tv/asijuyetuc

I’m trying it out on a Taotronics TT-BR06 Bluetooth receiver

0 Likes

#6

Um, that’s not going to look like a BT receiver to the system. It’s just simply going to look like an analog audio device.

EDIT: Is that device connected to your Pi? Or is that what you are trying to send to?

0 Likes

#8

You installed bluez and others before the a2dp package so that might have let to a conflict
Commandline: /usr/bin/apt-get-real install alsa-utils bluez bluez-tools pulseaudio-module-bluetooth python-gobject python-gobject-2

Try to remove a2dp and all the packages above, then do a autoclean and try to only install a2dp from OSMC

0 Likes

#12

also tried this BV210 bluetooth speaker

0 Likes

#13

ah I see. could I trouble you with asking for the instructions on how to remove those packages? noob

Ok I’m using sudo apt-get --purge remove

0 Likes

#14

sudo apt-get purge alsa-utils bluez bluez-tools pulseaudio-module-bluetooth a2dp-app-osmc
sudo apt-get autoremove
sudo apt-get install a2dp-app-osmc

Hope that are the only packages that you had installed not sure of older history

0 Likes

#22

Ok did the purge and then reinstalled a2dp-app-osmc. Trying it with a UE Boom 2 bluetooth speaker but connection failed.

[bluetooth]# trust C0:28:8D:8C:8F:BB

[CHG] Device C0:28:8D:8C:8F:BB Trusted: yes

Changing C0:28:8D:8C:8F:BB trust succeeded

[bluetooth]# connect C0:28:8D:8C:8F:BB

Attempting to connect to C0:28:8D:8C:8F:BB

Failed to connect: org.bluez.Error.Failed

0 Likes

#23

bluetooth.service - Bluetooth service

Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)

Drop-In: /etc/systemd/system/bluetooth.service.d

└─local.conf

Active: active (running) since Tue 2019-03-19 21:31:06 EDT; 7min ago

Docs: man:bluetoothd(8)

Main PID: 488 (bluetoothd)

Status: “Running”

CGroup: /system.slice/bluetooth.service

└─488 /usr/libexec/bluetooth/bluetoothd

Mar 19 21:31:06 osmc systemd[1]: Starting Bluetooth service…

Mar 19 21:31:06 osmc bluetoothd[488]: Bluetooth daemon 5.43

Mar 19 21:31:06 osmc systemd[1]: Started Bluetooth service.

Mar 19 21:31:06 osmc bluetoothd[488]: Starting SDP server

Mar 19 21:31:06 osmc bluetoothd[488]: Bluetooth management interface 1.14 initialized

Mar 19 21:31:06 osmc bluetoothd[488]: Failed to obtain handles for “Service Changed” characteristic

Mar 19 21:33:28 osmc bluetoothd[488]: a2dp-sink profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:33:28 osmc bluetoothd[488]: a2dp-source profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:33:42 osmc bluetoothd[488]: a2dp-sink profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:33:42 osmc bluetoothd[488]: a2dp-source profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

0 Likes

#24

Did you reboot?
Upload logs again grab-logs -A

0 Likes

#25

thanks here you go ;https://paste.osmc.tv/xeqifikeha

yes did a reboot

0 Likes

#26

Yeah I’m trying 3 different bluetooth speakers (all of which I can connect to with my mac and phone)

bluetooth.service - Bluetooth service

Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)

Drop-In: /etc/systemd/system/bluetooth.service.d

└─local.conf

Active: active (running) since Tue 2019-03-19 21:39:37 EDT; 6min ago

Docs: man:bluetoothd(8)

Main PID: 493 (bluetoothd)

Status: “Running”

CGroup: /system.slice/bluetooth.service

└─493 /usr/libexec/bluetooth/bluetoothd

Mar 19 21:41:11 osmc bluetoothd[493]: a2dp-sink profile connect failed for FC:58:FA:7A:07:55: Protocol not available

Mar 19 21:41:28 osmc bluetoothd[493]: a2dp-sink profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:41:28 osmc bluetoothd[493]: a2dp-source profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:42:35 osmc bluetoothd[493]: a2dp-sink profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:42:35 osmc bluetoothd[493]: a2dp-source profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:44:18 osmc bluetoothd[493]: a2dp-sink profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:44:18 osmc bluetoothd[493]: a2dp-source profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:44:42 osmc bluetoothd[493]: a2dp-sink profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:44:42 osmc bluetoothd[493]: a2dp-source profile connect failed for C0:28:8D:8C:8F:BB: Protocol not available

Mar 19 21:45:01 osmc bluetoothd[493]: a2dp-sink profile connect failed for FC:58:FA:7A:07:55: Protocol not available

0 Likes

#27

BV210, Taotronics T-BR06, and UE Boom 2

0 Likes

#28

My gut feeling tells me that something must have messed up with the different packages.
At this moment I only could suggest a clean reinstall.

0 Likes

#29

Of OSMC?

0 Likes

#30

Yes

0 Likes

#31

As you have a Pi, just install a clean system on a second SD Card. Install ad2p and try if that solves your issue.

0 Likes