Bluetooth audio streaming issue


I followed this thread instructions to be able to stream music from my phone to my AV receiver connected through HDMI to my brand-new Vero 4K. After spending some times to find out how to enable bluetooth (I’m new to OSMC…), I succeed to pair my phone and stream my music :slight_smile:

But I have issues with audio output, I hear some background static noise and the sound seems slightly deformed, whatever the source file. What could be the cause? Is there some configuration parameters to tweak?

I haven’t any issue when I play music or movies stored in my attached hard drive or through upnp. Tried to reboot several times and changed audio settings doesn’t help. I don’t think this is related to my phone as I have no problem when I stream to my laptop.

I know this is an experimental feature so I don’t expect high priority support, but I’m wondering if someone has tried this setup with the vero 4k has the same issue.

I can provide debug logs if needed.

The Bluetooth streaming support isn’t ready for Vero 4K yet. We’re hoping in a few weeks we’ll have it ready for all OSMC platforms.

PulseAudio is probably mangling the audio. I’d advise against using Bluetooth streaming for now.

Ok Sam, thanks for your quick feedback.

For Verok4k I have managed to get BT audio running after editing /etc/pulse/daemon.conf and setting:
default-sample-format = s32le
default-sample-rate = 48000
default-fragments = 2
default-fragment-size-msec = 16

After edit: sudo systemctl restart pulseaudio.service or reboot

1 Like

Thanks Aun, I will try this.