Bluetooth audio streaming problems


I want to be able to play audio to OSMC via Bluetooth;
Currently it’s installed on a Raspberry Pi 3 witch has support for both Bluetooth and WiFi by default,
I searched about streaming audio to it and came across a post about A2DP service, I installed it as the post said but I couldn’t get it to work,
My phone is a Samsung Galaxy J5 2016 witch as far as I know supports A2DP streaming, I paired it with Kodi/OSMC, it was successful but after pairing I got an error wich said “Connection to Galaxy J5 failed”
On the phone’s side, Kodi (witch I named DirectLink) is shown as a computer, not as a BT device that I can stream to, It won’t let me connect to it (like I do with my Sony RDH-GTK17iP - Bluetooth enabled boom box)
The steps I followed to install A2DP were the same as in the post about it, only that I ran them via SSH Shell I don’t think that’s a problem though :slightly_smiling_face:
Could someone help me to set it up?

The internal bluetooth of the RPI3 is known to have issues with audio, you should use a external bluetooth dongle instead.

The current A2DP version has some issues and is not useable without tinkering. Suggest you wait for an update that might come on a2dp

I’ve read posts in witch people said that they got it working with Rpi3’s internal Bluetooth.
I don’t even know with what I could tinker to be able to use this service (Any advice?) :)) last update on A2DP was in april 2017 I expect some progress since then

It got broken In January 2018 when OSMC moved to stretch. In the moment the “tinkering” I can suggest is only to fix for Audio from OSMC to bluetooth speaker and not for from phone to OSMC. So sorry I think you need to wait for it to be fixed in the future.

:frowning: it’s a shame really, I don’t need to stream from OSMC, I have it connected to my home stereo through HDMI, it’s the best connection type for me :stuck_out_tongue:
Streaming from OSMC is useless, now that YouTube app is kind of broken on kodi (won’t play some videos) streaming to it via Bluetooth would’ve been super helpful

What are instructions to currently get it working from osmc to Bluetooth speaker?

Tried bluetoothctl from command line can get it to connect but it immediately disconnects after.

This is what works for me