Bluetooth connection not working


I’m trying to get the embedded Rpi3 Bluetooth running in order to stream audio. But I get stuck right from the beginning. (Btw, I saw some people using a bt dongle…. Why ? if it’s integrated already)

The following command is what I started with. Everything looks ok.

sudo apt-get install armv7-bluezalsa-osmc

But when I run this


I get a message that it’s waiting

Waiting to connect to bluetoothd…

And I cannot find anything in my bt available devices list, on my phone.

What is the problem you think ?

Thank you

You should not have had to do that. Are you perhaps following some outdated advice?

If you are using WiFi and BT at the same time, it can be better to add an external dongle. Still you should be able to pair and connect a BT device.

Please post logs so we can see your setup better.

Thanks. Yes, definitely… I’ve been reading outdated posts, several to be honest and then once I realized, I tried to do some cleanup. I however thought that this first command was correct.

I am not using Wifi, I’m wired.

Here is the log access:

You need to get rid of pulseaudio. We don’t support it.

Have a look here [How-to] set up Bluetooth audio

Pulseaudio removed. Still the waiting… message.

This is where I got the instruction for the following command (very first paragraph) to install armv7-bluezalsa-osmc.

But you are running Kodi 19.4 already which includes that package. No harm done - it should have just told you nothing to update.

Let me fire up a RPi3 and see if I can reproduce this. It’s bluetooth (bluez) that’s not starting up, not the bluez-alsa package.

Hi grahamh, any chance you had time too check this ? Thank you

I did find a RPi3, updated it, and had no problems. I’ll check your log against mine later.

What is the output of lsmod and systemctl status bluetooth?

And can you post logs again now you have removed pulseaudio.

Thank you.

Here is the output of lsmod:

Here is the output of systemctl status bluetooth:

And here the logs:

Hmmm. Try sudo modprobe bluetooth. What happens?

Nothing… At least, nothing noticeable.

After the modprobe, does bluetooth show up in lsmod?

Seems like it:

But still waiting to find any bluetooth device with bluetoothctl command

So now how about systemctl start bluetooth then systemctl status bluetooth?

Stopped by itself after started it.

Reaching the limit of my knowledge. Maybe your flirtation with pulseaudio did something bad although I don’t understand why the bluetooth module isn’t loading automatically. Try reinstalling bluez and bluezalsa.

sudo apt-get install --reinstall armv7-bluez-osmc
sudo apt-get install --reinstall armv7-bluezalsa-osmc

Unfortunately, not better… but the result of the systemctl status bluetooth is now different:

All I can suggest is if you have a spare SD card, reinstall OSMC.

OK… :face_with_diagonal_mouth:
I was waiting to get a Rpi4 to re-install it all, but wanted to get a head start…
Thanks a lot for your time.

1 Like