Bluetooth Dongle RPi3

Hi Guys

First post. Thanks in advance.

I have an RPi3 with OSMC. The native bluetooth wasn’t working well for connecting headphones so I purchased the dongle recommended by OSMC from their website. It arrived, plugged it in, still cannot connect.

It seems it is still defaulting to the Pi bluetooth as opposed to the dongle?

Wondering if I am missing something regarding installing the dongle? Or how do I get it to default to the bluetooth dongle?

I did search on the forum and couldn’t find anything aside from a github article which is over my head on how to disable the Pi bluetooth.




to config.txt; then reboot and internal adapter will be disabled.


Thanks Sam.

I did this, and there is still a Bluetooth option presumably from the dongle but still cannot connect, same error as before, so it’s either not disabled built in Bluetooth, or these headphones don’t work with the dongle.

Did you install the A2DP package?

What are they? Maybe someone else has got them working.

I did, but that was prior to the dongle. Might rebuild and try again.

To change the default Bluetooth that gets used from the command line when you have multiple. Run these commands.

bluetoothctl #opens interface
list #list controllers
select xx:xx:xx:xx:xx:xx #make default controller use mac from the list
quit #close the interface

1 Like