Bluetooth gets disconnected after latest update

Hi Guys,

OSMC on PI2. After updating to 2016.04-01, Bluetooth seems to be broken: it’s connecting to my headset but then immediately disconnecting.

Any idea?



Hi. I have the same problem of @adilei. After April Update my Bluetooth device connected and immediately disconnected. Thanks

What kind of bluetooth device ?

@adilei is having trouble with a headset - audio streaming support in OSMC is still extremely experimental (hence the experimental/testing thread where the bluetooth audio support is being tested) however other kinds of non-audio devices should work ok.

We would really need to see log files taken when the problem occurs to have any idea of what is happening though.

It’s a Bluetooth headphones (Aukey EP-B4) and dongle Bluetooth 4.0 CSL (a2dp).
I use ALSA: OSMC streaming to Bluetooth speaker/headphones.
Here is the log

1 Like

Not sure if it’s significant, but this was in my log as well:

ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

That error is not an error and is unrelated.


You need to unpair, untrust / forget the device and reconnect.

I’ve tried that several times - did not seem to have any effect. However “downgrading” to 2016.02-3 resolved the issue.

thanks Sam, i have already tried to forget the device and new pair but the problem persist.
I hope that downgrading is not the only solution…

hi. anything news about the problem?
I have removed the device but the problem persist…

osmc@osmc:~$ bluetoothctl
[NEW] Controller 00:1A:7D:DA:71:15 osmc [default]



We are aware of the problem and should have a resolution in the next update


1 Like

Thanks Sam for reply.

Hi. Also with new update 2016-04.2 the Bluetooth device connected and immediately disconnected. Bye.

Hi @sam_nazarko nothing new? Thanks

It’s been fixed, it will be pushed in the next update

1 Like

Ok. Thanks a lot

Great work. With new update 2016-05.1 the Bluetooth device connected and stayed. Thanks. Bye.

Bluetooth is stable for me as well, however now there’s no sound output even with HDMI…

I’m having the same problem and despite I’ve upgraded to the last version I still can’t connect to my earphones. This is also a Aukey BP-E4 device. The message I get is:

CHG] Device 00:30:00:00:12:F6 Connected: yes
[CHG] Device 00:30:00:00:12:F6 UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 00:30:00:00:12:F6 UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 00:30:00:00:12:F6 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 00:30:00:00:12:F6 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:30:00:00:12:F6 UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 00:30:00:00:12:F6 Paired: yes
Pairing successful
[CHG] Device 00:30:00:00:12:F6 Connected: no

any suggestions?