Bluetooth issues after March update

Hi. Since the March update my harmony smart remote (with Bluetooth hub) won’t connect to vero 4K+ via Bluetooth. A number of devices would normally populate under the ‘Available Devices’ section in my osmc, but this isn’t happening now. I’ve rebooted the hub and tried again but no luck. Vero has always been pretty easy to pair with harmony in my experience. If you need me to test anything I should be available later this eve. Thanks in advance.

Hi,

You could try pairing from the command line

Thanks Tom.

Thanks Tom. If I’m feeling brave later on I might give this a go, although I’m not particularly confident using command line. Always got the vero remote as a backup in the meantime. Cheers.

Alternatively please provide some logs, may shed some light on what’s going on:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

This happened to me on my original Vero 4K. I just used the original Vero remote, went into MyOSMC, Network, Bluetooth and disabled bluetooth then re-enabled bluetooth and waited for the Harmony Keyboard to show up in Paired Devices. Now all is good.
This did not happen on my Vero 4K+.

1 Like

Thanks for the help guys. Strangely, I had tried disabling/re-enabling Bluetooth as suggested a number of times yesterday and this morning with no luck. Just tried again and harmony appeared under devices and connected. Weird, but glad it’s sorted. Thanks.

1 Like

Can I ask please, now that bluetooth is working again for you @Tee77 does your harmony remote and hub still have all the keys mapped as before the update?

I have a Harmony Hub and remote and I’m concerned that I’ll lose my mappings. Don’t want to have to redo them all again having spent ages getting exactly what I want.

Thanks

-Mat

Pairing has nothing to do with mappings so this should not be an issue.

Looks like you already have the answer from someone who knows more than me. Unfortunately I ended up wiping my harmony remote/hub yesterday whilst trying to get this to work. :confused:

How did you manage that? The hub gets programed the same as the ir remotes don’t they? Did you remove the profile in the PC software?

Thanks both. My limited understanding from reading the blog was that this ‘new way of doing things’ uses a keymap file and I think I already have one of those. I’ll have a check and backup if I can find it then.

Thanks
-Mat

So this “new way” mainly concerns the OSMC remote controls. If you don’t have a dongle for one of those remotes plugged in this new custom keymap is not loaded. If you use a keyboard, or another remote or controller that presents itself to Kodi as a keyboard then there may be some interaction which you can mitigate by turning off the custom map as outlined [here].

If you have existing keymaps your using in your userdata folder (including what is created by the Keymap Editor add-on) these are not deleted, modified, or disabled. Any existing keymaps are actually loaded after our new custom map so your tweaks will not only stay in place, they will also affect the OSMC remote as well.

I know! I reset the hub/remote’s profile from the iPhone app intentionally as I wanted to eliminate the harmony hub being the problem when trying to connect to Vero via Bluetooth.

Also, looks like I spoke too soon. Successfully paired the hub with vero via Bluetooth earlier, all looked good. Rebooted vero just now and the Bluetooth pairing has disappeared. Repaired again, connected via Bluetooth, rebooted, and same again…Bluetooth profile on vero has disappeared.

As suggested previously I should now probably upload a log, yes? Try and pair again via Bluetooth, enable debug logging, reboot and upload log? (Sorry, bit of a novice with this stuff).

That would probably be the best course of action. I can’t help with the bluetooth hub pairing stuff myself but without logs the people who can are limited on how much they can assist.

Yep, Bluetooth lost connection again. Hope I’ve done this correctly…

https://paste.osmc.tv/asegaleviq

1 Like
Mar 26 16:42:09 osmc hciattach[406]: Initialization timed out.
Mar 26 16:42:09 osmc hciattach[406]: bcm43xx_init
Mar 26 16:42:09 osmc hciattach[406]: Flash firmware /etc/firmware/BCM4345C0.hcd
Mar 26 16:42:09 osmc systemd[1]: sdio-bt-firmware.service: Control process exited, code=exited status=1
Mar 26 16:42:09 osmc systemd[1]: Failed to start Vero3 Bluetooth support.
Mar 26 16:42:09 osmc systemd[1]: Startup finished in 3.491s (kernel) + 32.717s (userspace) = 36.208s.
Mar 26 16:42:09 osmc systemd[1]: sdio-bt-firmware.service: Unit entered failed state.
Mar 26 16:42:09 osmc systemd[1]: sdio-bt-firmware.service: Failed with result 'exit-code'.

This is the same error as in Bluetooth audio March update

Can you run the following commands:

sudo systemctl start sdio-bt-firmware.service
systemctl status  sdio-bt-firmware.service

and show us the output.

Interesting. Thanks for the response. I do have a keyboard somewhere but I’m an absolute novice with regards to this. If I plugged a keyboard in, how would I access the command line? And is this all one command? Need to brave a supermarket as the cupboards are bare but will try when I get back. Thanks.

Probably easier to SSH to the box, though an attached keyboard will work. See https://osmc.tv/wiki/general/working-with-osmc-via-the-command-line

Hi. Managed to SSH in to Vero and ran the commands one at as time. Hope I’ve done it right. If not, let me know and I’ll have another go. Thanks.