Bluetooth PS3 Gamepad not connecting on default

As the title already implies, I do have complications connecting a PS3 Gamepad to the RPi2 via Bluetooth.
First of, I followed this guide which worked fairly well, besides some compiling errors, in order to get rid of them I used a newer version of QtSixA from GitHub, which compiled flawlessly. After the installation of sixad I enabled Bluetooth via connman and now there’s only one thing left to do: Starting sixad. This turned out to be more difficult than I expected, since I’m basically stuck here.

osmc@osmc:~# sudo sixad -s
[ ok ] Starting bluetooth (via systemctl): bluetooth.service.
sixad-bin[2286]: started
sixad-bin[2286]: sixad started, press the PS button now

The Gamepad is simply not recognizing the bluetooth-device, or the other way around. To make sure both are working correctly, I did the same thing on a regular Ubuntu x86 machine and everything went fine. The activity led on the bluetooth dongle was actually flashing, which was not the case when attached to the RPi2, so I had a look at the hciconfig output:

user@vbox:~# sudo hciconfig
hci0:   Type: BR/EDR  Bus: USB
        BD Address: XX:XX:XX:XX:XX:XX  ACL MTU: 310:10  SCO MTU: 64:8
        RX bytes:6219510 acl:107254 sco:0 events:203 errors:0
        TX bytes:7541 acl:114 sco:0 commands:74 errors:0

On the Raspberry Pi the output looks similar but the PSCAN status was missing, so I enabled it manually with the command “hciconfig hci0 pscan”. The dongle started flashing, but after starting sixad again, everything went back were it was, which probably means sixad is stopping the page scan. Just out of curiosity I opened a second terminal window, and started pscan again. Now the gamepad connects an is usable. In order to connect it, I have to go through these steps every single time, which makes it difficult to automate this process for example on startup.
If anybody knows a better workaround or any thoughts on this issue, feel free to share it.
Thanks in advance!

Continuing the discussion from Enabling bluetooth:

hey Theetjuh,

you seem to be the only person around the web that actually solved the problem :stuck_out_tongue:

I actually don’t really get how you exactly solved the problem. I actually only want the rpi2 to be a media center (kodi), i don’t need any emulators. To achieve the best performance, I have OSMC (newest Version, RC2) running. Is there a way to get the DS3 working, or do I have to install the RetroPie image?

I would love to have OSMC or openelec (which people say isn’t possible because of missing xorg) with added DS3 support.

Would be very kind of you if you could get a little bit more into detail, but I am happy with anything you throw at me haha