Bluetooth speaker connected but no sound

Yes, should be all as # just is comments who don’t matter.
Let me know the URL of this command that I can check your .asoundrc.
paste-log .asoundrc

The < and > are part of what you should have replaced.

# This file describes the bluetooth sinks available for Kodi to play to
# add lines like the following for each BT device (speaker or headphones)

pcm.mybtdevice {
        type bluealsa
        device "d4:12:43:11:06:c9"
        profile "a2dp"
        hint {show on description "Speaker"}

# using the MAC of the device (see bluetoothctl) instead of 12:34:56:78:9A:BC
# Use any letters or numbers for the description which will show up in Settings-System-Audio

I made that edit and the function appears to be the same. I have the same options as before for audio outputs. Thank you for assisting with this. I have a pretty basic understanding with it all so far.

When I run the ls command I get this

Movies Music Pictures TV Shows armv7-bluez-alsa-osmc.deb

but the last option is in red text. Is that how it should be?

Did you exit Kodi after making the change?
Also can you start bluetoothclt show output of show d4:12:43:11:06:c9

I rebooted my device. Do I need to do something more than that? bluetoothclt says command not found. I figured out it’sbluetoothctl

Sorry I made two mistakes. Corrected below

Also can you start bluetoothctl show output of info d4:12:43:11:06:c9

That is ok, red text only means different permission.
That file is not needed anymore after successful installation.
Let’s quickly check if installation was fine.
Can you post output of dpkg -l | grep blue

osmc@TatesOSMC:~$ bluetoothctl
[NEW] Controller D4:12:43:11:06:CA TatesOSMC [default]
[NEW] Device F8:DF:15:B4:27:65 JBL Flip 4
[JBL Flip 4]# info d4:12:43:11:06:c9
Device d4:12:43:11:06:c9 not available

osmc@TatesOSMC:~$ dpkg -l | grep blue
ii armv7-bluez-alsa-osmc 1.0.5 armhf Bluetooth audio streaming for OSMC
ii armv7-bluez-osmc 5.43-3 armhf bluez for OSMC
ii bluez 9.99-10 all bluez transitional package for OSMC
ii bluez-tools 0.2.0~20140808-5+b2 armhf Set of tools to manage Bluetooth devices for linux
ii libbluetooth3:armhf 5.43-2+deb9u2 armhf Library to use the BlueZ Linux Bluetooth stack
ii pulseaudio-module-bluetooth 10.0-1+deb9u1 armhf Bluetooth module for PulseAudio sound server

Ok you entered the MAC of the Controller not the JBL.
Change asoundrc to device "F8:DF:15:B4:27:65"

And maybe also post output of info F8:DF:15:B4:27:65

Try sudo apt-get remove --purge pulseaudio and re-boot.

That worked! You’re the best! The only issue I’m having now is sometimes when I reboot the vero isn’t detecting an external hard drive I have plugged into it. I just have to reinsert the USB and then everything is normal

1 Like

That usually indicates power problems. Try plugging your drive into powered hub (if the drive isn’t self-powered)

is it possible to make multiple profile for different bt devices?

Should be possible.
@grahamh might have an opinion.

Yes. Just make another entry in .asoundrc with the device details, like

pcm.mysecondbtdevice {