Bluetooth streaming no longer works after todays update 07-1

I was prompted today to download latest OSMC (settings page says OSMC July 2017.07-1 - )
after this update an error appears on boot up which says “BTplayer failed see log for more details”
Its difficult to find the log as there is no viewer in OSMC and one is reduced to guesswork rummaging round an SSH session.
I did try “sudo journalctl” and one of the last lines in that said ‘Service failed to start “org.bluez” timed out’
So I reckoned something wrong with the BT driver - only in June @Sam Nazarko was emphasising A2DP was still experimental. So I tried to reinstall the a2DP package only to get 'Newest package is already installed"
Well I’m game for trying things but I am no expert on Debian/commandline stuff - I am stumped
Trouble is this is ‘wife’ critical - no sound on telly (I’m getting nothing on HDMI either)
Am I right in saying there’s is analogue sound on the Vero 4k? is the inside jack a an audio one? (the scrappy paper which comes in the box doesn’t even have a set of labels of the sockets) On Settings there seems to be no equivalent of the analogue option one gets on the Raspberry pi. - the only two option are HDMI and BT streaming

I have been using Bluetooth on one vero 4k happily for months and an optical connection to a sound bar on the other.

I’ve uploaded the log to the cloud as before but I’d appreciate any rapid help to get back up and running
Good job the oven doesn’t have regular updates- we’d be eating out :wink: perhaps I’m going to have to.


Try to update again.

I guess because you quoted some other post you mean for me to use “sudo systemctl…” ?
It is not possible to 'try the update again" using My OSMC because it simply says ‘latest version installed’
Please dont assume I am fluent in all things command line.

No I meant to try to update again as Sam has published an update that fixed the Bluetooth which was by mistake broken.

If that is the case than upload logs please

My response was as of 12 hours ago. I have now had message ‘updates available’ and yes as per the other post where the bluetooth keyboard wasnt working, this patch fixes bluetooth. (I had hte same symptons -i.e. clicking 'discovery check box simply caused it to flash and yes I do research other posts and try to fix things myself :wink:
Now however, although I can connect the bluetooth audio and I can get sound out when I play music no sound comes when watching live TV
FWIW I use DVBLink pvr and backend. In common with yet another post the last two upgrades have degraded the performance of DVBlink - it takes a lot longer to load the guide and PVR info. The playback is now very blocky and freezes every few minutes where it did not before Some channels simply wont play when they did before the update.

BUT my initial problem is that live TV play no sound over bluetooth or analogue. Videos DO send sound and at first seem not to freeze - but I have tried playing 2 just now and both completely locked the Vero (power off reboot) after a few minutes play.
I have just uploaded the logs - I recall these are supposed to be ‘debug’ but I cant find any setting to switch ‘debug’ on or off.
the logs are

I suggest that you open a new thread with approriate title for this issue to not confuse people

thanks for your helpful reply