Boot fails with "failed to Create Volatile Files and Directories"

I’ve had this happen several times now.

I start with a fresh installation of OSMC - via NOOBs. Then force an update. Redo all my personal configurations, and then start using it. Works fine. After a few days or so, if I try to reboot, I get the kernel/systemd error: “failed to Create Volatile Files and Directories”. At that point it hangs, and all I can do is to reboot (actually unplug from power, then plug it back it). But still get the same thing.

I thought it might be the SD got corrupted. I’ve taken the SD card and checked it on another linux system (ran e2fsck and dosfsck on all partitions, copied the data from ~osmc/.kodi), and it seems okay.

The only thing I could think of doing at that point was to do a fresh reinstall of OSMC. Even tried with a new SD card.

I don’t have this problem running Kodi on a windoz Laptop or linux desktop. Just with the RPi with OSMC.

This is getting pretty frustrating at this point. Kind of makes the RPi useless if I can’t get this to work. So any help will be greatly appreciated.

TIA

ken

Try using the OSMC installer.

http://osmc.tv/download

When you checked the card on another Linux machine did you check how much free space was left ? The error you’re describing would probably only occur if either:

A) the root file system is corrupt
B) the system has booted with the root file system in a read only state (Probably due to A)
C) no disk space left.

There is 5GB+ space left on the root-rpb1 partition, so not C.

The file system probably did get corrupted (as in A), although it does not show up when I fsck on it (the card on another machine). And I can view/copy from/edit files on the root partition. So, the question is: where could the corruption be? Any ideas on how to find that to fix it, before reinstalling the entire OSMC again?

Along those same lines: how did the file system get corrupted? Is it possible that leaving the RPi running for several days may cause something like this? My last install ran for 11 days before dying like this.

Thanks for the reply.

ken