Boot from nfs not working

I’ve installed osmc on my raspberry pi with nfs support. The install worked fine, if I look in my share the files are there. But then when I try to boot my pi it doesn’t boot at all. Any ideas what could cause this? I’m running an nfs server on my freenas server.

Did you leave the SD card in? OSMC only installs / on the NFS server, the boot files remain on the SD Card.

Yes I did leave the SD card in. I see that there are 4 files on it after installing:

The install.log does show the following :

Thu Jan 1 00:00:21 1970 Extracting files to root filesystem
Thu Jan 1 00:00:21 1970 Starting extract process …
Thu Jan 1 00:00:21 1970 Extracting from /mnt/boot/filesystem.tar.xz
Thu Jan 1 00:00:22 1970 Halting Install. Error message was: tar: can’t open ‘bin/busybox’: Operation not permitted
Thu Jan 1 00:00:24 1970 Extraction of root filesystem completed

It gives an error, but says the extraction is completed, and in the last line it says:

Thu Jan 1 00:00:24 1970 Successful installation. Dumping log and rebooting system

So I assumed it was installed correctly, any ideas?

I found the sollution! It had to do with the permissions on the nfs directory, I thought since there were files there the permissions were ok. But turns out the user right weren’t set at all in freenas, after that it worked!
Thanks for the help though!