Boot loop after update, ESC / cmdline doesn't work

Hi! Since some days i’m having troubles booting my osmc.

It started when I tried to use the Youtube - Plugin, where I always got asked if I want to run the Setup - Wizard. I always declined and ran the osmc updater. After the update I got stuck in a boot loop.

So I pressed ESC during boot and got the terminal. But I could not login as my credentials where not accepted (tried the factory settings “osmc / osmc” as well as the credentials I’ve set manually). I also tried to login as root. But everything I tried got denied.

To resolve this, I edited the cmdline.txt.

This is the original cmdline.txt:
root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2

I changed it to:
root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2 init=/bin/bash

Now I was able to boot into the cmdline without getting asked for the password, but my keyboard (wired) did not get recognized (did not react to keypress).

I also read that there could be a problem with the user - settings.
So I edited the cmdline.txt to
root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2 init=/bin/bash “mv ~/.kodi ~/kodi-bak”

As a result, instead of the sad face I first got the “osmc - logo” but after some seconds the sad face appeared again and the boot loop started.

And now I’m really lost and don’t know how to resolve this issue.
Worst case I have to reinstall my osmc, but to be honest I have some python scripts in the home folder… and … did … not … make … a backup (yeah, foolish…)

Any help is really appreciated!

Maybe there is a way to manually reset the osmc password during boot? Something like

If you have another linux box or a raspbian SD card to boot the Pi you can always get those scripts back with a card reader.

I have a Mac but when I plug the SD in my Cardreader I only get the “source” files, not the content of the image… :frowning:

What kind of “source” files? Can you show a file list?

With “source” (sorry for the confusing description) I mean the files initially written to the sd card like “cmdline.txt”, the kernel files, “config.txt” etc.

Ok, that are the files on the boot partition (formatted FAT32), the main data is on the second partition that is formatted in EXT4 which Mac OS may can not read without external software.
The quick and dirty solution is to run a Linux in a Virtual Machine (e.g Virtualbox) to read the data on the second partition

Sounds like a solution! I will try this and tell you if it worked. Many thanks in advance :slight_smile:

It could be your ext partition is borked and you will need file recovery tools. Good luck!

Did you change the OSMC password?
If you didn’t, I’m not sure that resetting the password would help anything