Boot twice each reboot

The new OSMC gives me troubles when rebooting. It always first makes recovery boot afterwards a normal boot. This destroys my external harddrives which start to power up on the first recovery boot and gets instantly killed, when going into normal boot. This is not healthy for my harddrives - is there any way to skip the “recovery boot”?

This should not be happening. Make sure your devices are getting enough power and you are shutting down correctly.

Okay mhm, weird. My external harddrives are having the own power supply and my RPI has a 2,5A 5V PSU… Not sure what is going wrong.

How are you shutting it down?

reboot from terminal? :slight_smile:

Does it do the same thing if you disconnect the drives? How are the drives mounted, via fstab or automatically?

Yeah automatically mounted.

This is the content of /etc/fstab:
LABEL=boot-rbp2 /boot vfat defaults,noatime,noauto,x-systemd.automount 0 0
/dev/sda2 /home/Frederik/HDD hfsplus force,rw
/dev/sdb2 /home/Frederik/HDD2 auto umask=000 0 0

However I am also having a minor problem with some bluetooth/hostname stuff as I can see on bootup. Something “dev-disk-by” (can’t remember the exactly line). If needed I will have to restart again :smiley:

Mounting by the device name is a bad idea since the drives may not always spin up in the same order. Use the partition label or device ID instead. My guess is that the drive you think is sda is sometimes actually recognized as sdb. You should also use the x-systemd.automount option.

How do I get the partition label or device ID?

I thought that (/dev/sdXX) was the partition label? :slight_smile:

If it is obtained by “fdisk -l” then you maybe could give an example of a partition label? Because I am not sure what to look for?


sudo fdisk -l

will return something like this:

Disk identifier: C5FC5FC3-F5E1-4A12-BCB0-A89A70EB7B35

With that, you’d change /dev/sdX with UUID=C5FC5FC3-F5E1-4A12-BCB0-A89A70EB7B35

I see now, so this would be better to use. Thanks for that :slight_smile:

Do you know anything about my issue with hostname and bluetooth on bootup? Otherwise I will go reboot later and come back with the full issue - If I can’t Google me to the answer. :smiley:

Thanks in advance, have a nice day.

That’s probably related to the mounts. Fix fstab first and see if that takes care of the problems.

I’m quite sure about that you are right about fstab problems… Worked fine with the partition labels. However this didn’t solved my problem about slow bootup. I have by a mistake overwritten the default fstab file which is given with the installation of OSMC and maybe that is the problem. After a reboot I have found the specific error message. It keeps trying to do the following three things:
A start job is running for:

  1. hostname service
  2. bluetooth service
  3. dev-disk-by\x2dlabel-boot\x2drbp2.device

Maybe anyone in here could send me the default lines in a fstab file from a fresh installation? :slight_smile:

/dev/mmcblk0p1  /boot    vfat     defaults,noatime,noauto,x-systemd.automount    0   0
# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/mmcblk0p2  /    ext4      defaults,noatime    0   0

Make sure that your external drives also use the x-systemd.automount and noauto options.

Why is this better?

If you don’t use it, boot times may be slower as it will hang during the boot waiting for the drives. And if you disconnect a drive the boot can hang.

The first line in fstab did the trick - dunno why.

Are you and expert on transmission daemon? :slight_smile:

If you have problems with transmission, start a new topic for help with that.

Okay - thanks :slight_smile: