Boot Vero 4K+ from USB stick


I have messed up network configuration, and now the device is not starting.

Now I want to fix this issue, and normally I would boot a live distro from USB stick and then chroot into the device OS.

However, I don’t know how to boot Vero 4K+ from USB stick.
The issue starts with that I cannot enter BIOS to select a boot device (USB stick).

Can you please advise how to boot Vero 4K+ from any other device and chroot the OS for emergency repair?


The Vero is not a PC so it doesn’t have a BIOS that you enter to choose the boot device.

Connecting a USB Keyboard and pressing Space/CTRL during boot up should bring you to an emergency console.

To boot a “Live” OS you would need a specific version on OSMC that boots from USB.

I would assume the device starts but just Kodi is not coming up (assuming that you have a SQL install). If that is the case you still should see a console screen and be able to login there when connecting USB keyboard.

My understanding is that I could boot any Linux OS that matches the Vero 4K+ architecture.
This must not be restricted to OSMC.

Anyway, I didn’t try to press Space/Ctrl during boot up, but I noticed that keyboard is not working correctly because I cannot enable keypad by pressing numlock (LED is off).

Unfortunately, I don’t get a console, instead OSMC enters a boot loop.

You can, but then you’d also need to mount the root partition loop back.

You could get to a console as @fzinken has suggested and make the necessary changes there.


I cannot enter emergency console.

Can you please advise

  1. which key combination must be pressed on keyboard? Is it Ctrl+Space?

  2. When I must press this key combination? As soon as the red LED on the front panel is on?

Besides this I’m pretty sure that my USB keyboard is not working with Vero 4K+ because no LED on the keyboard can be turned on independent which USB port of Vero 4K+ used.


I would need to test again when I am with the Vero but would suggest you try just to start pressing CTRL (only) after you plug in power till you see a login screen.

EDIT: Just tested, pressing repeatedly CTRL after plugging in the power plug let me go to login screen (comes after the OSMC boot screen.

Unfortunately this is not working for me.

Try holding shift key during boot – this should load the initramfs recovery console. You can then mount the root filesystem and make the changes you want.

This is a lot “try & error”…
Anyway, I tried it and it’s not working.

Please note that the keyboard does not show LED for either Shift-lock or Num-lock.
Therefore I conclude that my standard USB keyboard is not identified as input device by Vero 4K+.

Did you tried to connect the Keyboard to the other USB port?

While in the meantime I believe a reinstall with reconfiguration might be the faster solution.