Both Vero 4ks crashed after update

Hi guys, I have just been doing the automatic update on my two Vero 4k+ devices. both are rebooting to the sad face of death.

It’s not cycling, just finishing on the sad face. Tried unplugging one to reboot it but no joy.

If it was one device, I’d put it down to bad luck but two is more than a coincidence.

Please let me know if there is any info I can send, I will need help with SSH though or pointing to some instructions.

Edit: I can’t access the devices through their IP address so may not be able to gather any info

Do you happen to have both of these boxes running the test builds and the Kodi.old.log has something like this near the end?

error <general>: failed to initialize EGL display (EGL_BAD_ALLOC)
critical <general>: CApplication::CreateGUI - unable to init windowing system
info <general>: Stopping the application...

If so then you will just need to hang on a bit to see what Sam has to say about it. I haven’t heard back from him yet since he asked me to test. He may fix it, he may just pull the update and a reinstall will be needed.

If that isn’t you issue then you will need to post some logs. To ssh from a modern Windows PC is just a matter of right click start>run> type “cmd” and hit enter then type “ssh osmc@” and hit enter and the password unless you changed it will also be “osmc”. To grab logs from the terminal you type “grab-logs -A” and it will return a url.

Here’s the log file link

I have no skill to interpret it.

I am going to reinstall on one device so my wife can watch TV and not shout at me.

Edit: found PVR

You have the Development/Testing Repository hardcoded in your sources.list. This is surely not recommended unless you know what you do. For the time being I suggest you wait a day and then update again. After the box is working again as expected remove the line deb bullseye-devel main from your sources.list.

====================== APT sources.list =================== ZZz2wrJ1
deb bullseye main contrib non-free

deb bullseye-updates main contrib non-free

deb bullseye-security main contrib non-free

deb bullseye main

deb bullseye-devel main

---------------------- APT sources.list END --------------- ZZz2wrJ1

I can solve the issue this evening

Please forgive my intrusion but I have the same problem, just a sad face repeating every few seconds.
Should I start new thread or join in here?

ps. I can access using ssh but no screen. How can I post a log and from where?

You will need to wait and update later

In future, unless you need to, I suggest staying with the stable repository.

You should now be able to update as follows:

sudo apt-get update
sudo apt-get dist-upgrade

And the issue should now be solved.

I suggest editing /etc/apt/sources.list and removing the ‘buster-devel’ line to avoid any unexpected updates.

I have no idea how that got in.

The only issues I have previously had have been when updates have not included the PVR, but I just posted here and an update was released that I got pushed out. I also edited a setting to try and get my favourite addon (TVShowNextAired) working but that was in the add-on code.

Can you point me to some instructions on how do I do that?

You would access the terminal and then type…

sudo nano /etc/apt/sources.list

and then in this text editor you would delete the last line that reads “deb bullseye-devel main” but do not modify any of the lines previous to that. You would then press ctrl+x, then y, then enter to save and exit.

And I forgot to say thank you to everyone. The clean install was probably worth doing one one box anyway.

Doesn’t hurt from time to time.

Thanks for your kind words