Box stuck in windowed mode!

Box is stuck in windowed mode and I now have no output, how do I get this back to fullscreen!


Do you have access via SSH?

Whats ssh ?

SSH is one way to get to the command line, the other one would be attaching a keyboard. But if you don’t have any picture currently on your TV Navigation could be tricky, therefore SSH would be easiest.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

If I had a keyboard what button should I press ?

s then ENTER and (after a few seconds) ESC you then should see a login screen.

Plugged in the USB keyboard and pressed ESC and s and enter and nothing happend, still no signal

The order has to be as I wrote s -> Enter -> ESC

Otherwise SSH is your only hope or connecting to another screen

All at the same time and on boot screen? I’m also connected to another screen and getting nothing

No one after the other (as written).
What do you mean with boot screen? If you reboot it is different. I was referring to when the devices is booted up and you don’t have a screen.
For boot screen you would use the combination written in the Wiki entry

I’m doping that command and the vero login appears with blue background but then goes to no signal again

It should not have blue background (have you checked other HDMI cables), but anyway you then have to login with username: osmc and password: osmc within 30 seconds.

Yes i’m in the comand prompt now

Ok first would suggest to create logs and share. Run grab-logs -A and share the code that is displayed here

We then can best suggest what to change to fix it.

That’s what come up when I typed the command

This is quite odd, did you had an update performed in the last couple of days?

How about paste-log .kodi/userdata/guisettings.xml

Also maybe instead of dissecting just try rm .kodi/userdata/guisettings.xml and then reboot

Wizard wizard! The second command line worked, thank you so much!

There any other command lines that I should know?

Well there are many more depending on what you want to achieve. But if you now have a picture back my first suggestion is to configure SSH access as that always is easier to troubleshoot.

Also suggest to figure out why grab-logs is not working, actually could now check MyOSMC → Log Uploader if that works.

Ok I will have a look at the log file from log uploader.

It isn’t connected to the internet but would recommend to and seeing if there is a update available?

Also what’s the command line reset the whole box and is there a website where I can find all the command lines?


Ok, without internet surly the log uploader doesn’t work.

Generally for security and feature updates it is recommended to keep the device connected to internet.

To reset Kodi (which is the main part you tinker with) this would do full reset

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

For a full reset including the OS you would need to reinstall via USB or SDCard.

There is no real list of commands to use but basically OSMC is based on Debian as OS and Kodi as the Media Center.

Here is a cheatsheet and some tutorials for how to navigate in a Linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems