Brand new USB drive randomly unmounting during music playback


so i purchased a brand new external usb drive (lacie usb drive) for my vero4k. Plugged it in (via a SBS branded USB 2.0 to USB-C 2.0 compatible cable after having copied my music lib onto the disk which is formatted as exFAT).

Added it as the new music directory, re-scanned via the vero osmc interface and played around with it… and all seemed fine.

Then after jogging about playing different tracks… it stops playing; and i discover that the volume on the disk seems to be no longer mounted / available.

So i played around a few times after having then rebooted the device and after another bit of randomly selecting tracks playing etc. it does the same thing again. I tried this both via the kodi web-interface and via the osmc interface on the TV… same issue.

So i reinstall the vero4k, since i’ve never had to do this before. Rescan the music lib… play around again with various tracks… and then same issue again.

I have used various microsd, usb, smb volumes and NAS devices since i have had this vero4k but this one is new.

If this is some kind of USB / power related issue then i would love someone at vero to explain why this is happening with the vero4k (I have the previous model not the recent/new version).

p.s. I will let some albums play out unhindered and see if the issue reoccurs and post logs if I encounter the same issue randomly. The drive in question is below…

LaCie Mobile Drive (2022) 2TB version

update: …It played first 8 tracks of a 12 track album before same issue of unmounting the volume.

Although I don’t see any power consumption specs listed in that manual or datasheet I think there is a high likelihood that its peak current demand exceeds the 500ma of the USB 2.0 spec of the port your plugging it into. I suspect if you attached it with a powered USB hub inbetween the drive and the Vero this issue would not happen.

Output is limited to 500ma on each port which isn’t enough for mechanical drives.

On Vero V the output of the USB3 is 900ma which can power more drives.

good point - will have a go and report back :crossed_fingers:

1 Like

thanks for the pointer … so do you think darwindesign’s suggestion of going via a powered usb hub would resolve this power difference issue ?

for example

USB-C 2.0 is kind of odd.
Can you provide a link for the cable you purchased?

I have powered Seagate external 4TB and 5TB 2.5" drives without issue on my 4K+ in the past.
It’s not recommended to do that but it is possible.
These LaCie drives might pull more power than the Seagate ones.
So a powered USB 3.0 hub is definitely the way to go, but I do find that cable you mentioned odd.
I’ve never seen a USB cable with a C connector spec’d for USB 2.0 before.

EDIT: Specs are kind of vague for this item but it appears to have a 7,200 RPM HDD in it (my Seagate drives were 5,400 RPM) and as far as connectivity I don’t see any mention of USB 2.0 compatibility only USB 3.0 type C, USB 3.2 Gen 1, USB 3.2 Gen 2 (USB 3.1), and Thunderbolt 3, all of which are spec’d to provide more power than USB 2.0. The manufacture probably doesn’t list USB 2.0 since that spec doesn’t provided enough power. The powered hub should fix that for you.

There is an approved hub in the OSMC store at 4 Port USB 3.0 Powered Hub - OSMC but any USB 3.0 powered hub should do the trick.

They are actually pretty common but are frequently just listed as something to the effect of USB C Charging cables without stating the protocol. They are normally a lot less expensive than a proper USB 3 cable.

thanks for the reply

this is the cable I’m using…

i will get that one, since i do not currently own one; will let u know how it goes

Wow, they are really using nonstandard terminology.
From their website:

Connector 2: Type-C
Connector 1: USB 2.0

That is horrible!
Connector 1 should say “Type-A” not “USB 2.0”.
So the cable looks like a USB 2.0 cable with an A connector on one end and a C connector on the other end.

SOOOOOOO, that cable may not be able to transmit the power reliably even if it is plugged into a USB 3.0 powered hub.
That would be my concern.
I would recommend you purchase a USB 3.0 Type-A to Type-C cable.


thanks, sorry for the delay - your point makes more sense with respect to wattage (e.g. 2.5W vs 4.5W) between USB 3 and 2 makes sense, will get a good quality USB 3.0 Type-A to Type-C cable today and try it out and let you know how it goes.

ok, so i bought a good quality USB 3.0 Type-A to Type-C cable today and tried it out and after about 10 mins it crashed / and powered down my vero4k. So the moral of the tale is… does not seem to work. I think i’m just going just going to upgrade to the new vero4k (and use as secondary guest room device) … however, can someone who knows at vero4k team confirm that it will work with the disk drive i recently purchased and a slave device…

e.g. via the site spec * 1x USB 3.0 port (0.9A output)

LaCie Mobile Drive – Externe USB-C-Festplatte | LaCie Deutschland

i purchased the 2022 2tb drive.

Vero 4K / 4K + can provide 0.5A which is insufficient.

Vero V can provide 0.9A from the USB-3 (blue) port which would be suficient.

1 Like

That drive plugged into a powered USB 3 hub and that hub plugged into a Vero 4K should also work.

yes i had figured as much, i think i will go this route.

just ordered new vero4k… joy! :slight_smile:

We will ship your Vero V on Monday with tracking.

For best results, use the new power supply that comes with Vero V.

1 Like

Got the device … all working perfectly. Very happy with it. :sunglasses:

1 Like

Glad to hear this!

1 Like