Brand new Vero 4k+ cannot find Wifi networks

Received a brand new Vero 4k+ today and dove straight into setting it up.

On the Network screen, wired is disabled and wireless is enabled. However the isnt a single wifi network found on either 2.4Ghz or 5Ghz. I’ve got both wifi networks operational and all other devices (TV, laptop, android phone) can see and connect to both neworks.

Obviously, an unable to ssh into the Vero 4k+ to run command line either.

What can be done about this ? Did i receive a defective unit ? Any help would be much appreciated. Thanks in advance.

Can you temporally connect it wired? If yes first I would check if an update is available Settings - MyOSMC - Updates - Manual Update

Also which channels are your 2.4 and 5Ghz networks using?

1 Like

I can connect directly to the AP’s LAN port but it’s too far from the TV for the HDMI cable and I wouldnt have a screen on it. The 2.4Ghz band is on channel 10 and the 5Ghz band is on channel 48. Set that explicitly after reading some posts here on channels < 100. Still no go for me.

Have also tried following the instructions to download an installer image onto a USB thumbdrive with the Aug 2021 image files, but when rebooting the Vero 4k+ doesnt seem to boot from the USB and update. It still seems to bootfrom it’s existing image.


Please see:


Thanks for the solution, @sam_nazarko. I’ve tried using the installer and making a USB thumbdrive image with the OSMC_TGT_vero3_20211006_wifi_fix.img.gz image, but the Vero doesn’t boot from the USB drive and thus doesnt update itself. I followed the instructions at Reinstalling OSMC - Vero 4K - OSMC

Is there something i have missed ?

Please show a screenshot of the contents of the USB thumb drive.



There you go !

If you don’t succeed with the upgrade via USB Stick you could try to connect to the Wired network you then should be able to connect via SSH and upgrade via command line.

Scratch that, must have been a faulty USB drive. Tried with a new one, and successfully updated to the October image, and wifi connects and works well now.

Thanks for all the help. @sam_nazarko and @fzinken !

Glad to hear this and sorry for the inconvenience.


1 Like