Brand New Vero 4K+ DOA?

#1

Got my new Vero 4K+ yesterday, plugged it in, and got the following error messages:

Any help? It’s a bit strange it happens with a new unit…

#2

Hi,

A reinstall should get you up and going:

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

Thanks Tom.

#3

Thanks.

Is the reason bad original image deployed in the factory or corruption in the internal storage?
I hope it doesn’t mean it will happen again…

#4

Hi,

I believe this is the case rather than corruption of the internal storage and once reinstalled you should have no further issues.

Measures have recently been put in place to prevent this, unfortunately it appears you have been unlucky and received one of the few units affected with this and from previous batch before the measures were put in place.

Thanks Tom.

#5

Indeed. This issue was already fixed a while ago

A reinstall will resolve things

Sam

#6

This issue was already fixed a while ago

That’s a bit strange, since I’ve ordered it from this website, just a week ago…

Anyway, I’ll re-install it today and report back. Thanks.

#7

What’s the order number? Obviously the factory images are installed in advance; so a week old order would’ve been prepared say, two weeks before in a larger batch.

If you’d prefer we can send you a new one, but there’s nothing wrong with the hardware itself

#8

Order #24753.

I don’t have a problem with installation the software, just saying it’s strange…

Btw, I couldn’t get the installer to write the image to a USB stick (I tried on Windows 10 and Mac OS X).
Eventually I used Rufus to write the .img file directly the USB, I hope it will work.

#9

This has since been solved; so new orders are not affected.

What happened?

A common misconception is that users think they can’t ‘select’ the USB stick option. But the whole option is greyed out, because the installer is asking where you wish to install OSMC; not where you wish to run the installer from. The Vero 4K / 4K + only supports booting from eMMC at the moment, so this is why the option is greyed out (you just click next)