Bricked Vero 4k TV?

Hi guys,
I hope everyone is keeping well and safe!
I was shuffling things around on my media NAS, after which I had to clean the Vero 4k TV, unfortunately for some reason, this has seemed to “broken” the software.
Following the “Reinstalling OSMC” article;

a: after plugging in a media storage device (USB & SD) & powering on the Vero, I receive this error message
“waiting for root filesystem device /dev/vero-nand/root” “Fatal error: could not find root filesystem device /dev/vero-nand/root - if this is a USB install please check the USB drive is connected.
OSMC initramfs Rescue Console.
For help and support see HTTPS://osmc.tv/

b. going through the same steps but this time forcing the Vero to boot from the attached media (USB or SD) nothing progresses, it only shows “please stand by” with the OSMC logo underneath

One anther topic, I had used the “My OSMC” GUI to create backups. How do I actually restore the system from one of the backup files? When the device was working and I tried “Restoring from backup” browsing to and selecting the “tar.gz” backup file, nothing would happen…

Would anyone have any ideas?
Many thanks in advance! :slight_smile:

Can you show the contents (file listing of the USB Stick).

Hi fzinken,
Sure thing :slight_smile:
The USB drive:


and the SD card:

I have tried both kernel.img & recovery.img to no success.

Looks like you extracted the content of the files on the USB Stick instead of writing the installer image!
How did you exactly created the USB stick?

oh, ah by downloading the installer and going through the on-screen options/instructions following this guide:
https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

That’s odd as based on what I have seen the stick should only have 3 files after the installer ran. Can you try again and then check the contents before booting from the Stick.

also have you chosen the Vero 4K Image, looks like you might have choosen Pi Image and install to USB?

oh my …. I’m embarrassed to say I had mistakenly manually downloaded and then installed the incorrect img file, PI instead of Vero…. ops. Ahah ummm ahaha thank you for helping to get it up and running once again! It’s now in the process of restoring a tar.gz backup. :slight_smile:

1 Like

Glad you are up and running again

Sam