Bridged WiFi access point

Would it be possible to extend the hotspot functionality of OSMC into that of a bridged WiFi access point? Enabling the hotspot currently creates a separate network, whereas I would like to increase the WiFi coverage of my existing network through my Pi’s wired network connection.

A possible way to realize this is provided here. However, I would prefer this to be persistent with future updates, and wouldn’t like it to interfere with other functionality.

I apologize for the non-answer, but honestly, this is not a great idea. If you want a wireless repeater, bridge, or whatever other type of method used to provide network connectivity to various locations, then this is really best done with hardware that was intended to provide this function. There is much that can be done with old routers and plenty of low cost network devices on the market to fill most any niche.

1 Like

I know, however that’s one more device permanently drawing power, while the Pi is there anyway. In my case, it’s just to provide a simple doorbell cam with a better connection. I think a Pi4 should be more than capable of handling that.

Perhaps you should direct the question to a forum dedicated to whatever OS your running. I’m guessing that isn’t OSMC if your talking about a RPi4, and I don’t think we even have working wireless bridging on the supported RPi’s at the moment.

I’m currently running OSMC on a Pi 3, but I already have a Pi 4 ready for as soon as you’ll release it for the Pi 4 :slight_smile:


Its possible, but is not supported by OSMC. I don’t believe there any plans support this in the future either.

Thanks Tom.

Have you seen this article on creating a bridged AP using connman? I haven’t done it but may have to give it a try myself as there are times it would be useful.

The Unix philosophy is to do 1 thing, really well. All-in-one solutions are a compromise where none of the offerings are usually great.

I use powerline ethernet to extend network coverage to different parts of my home. It only gets about 60Mbps, but it is very stable, unlike wifi.

A relative uses MoCA networking to extend his network to a disconnected apartment/garage with 2.5Gbps.

If wifi really is the best answer, consider using a PoE Ubiquiti AP. Those can be placed and directed to cover acres of land, if needed for about US$80. Plus, a normal CAT5e cable provides the power along with the signaling, so attic runs are pretty easy.

In a prior job, I did over 1200 wifi deployments and quickly learned that every location is a little different, and that wifi performance can change from day to day, hour to hour, based on all sorts of conditions outside our control. Wifi connections seem to always be worse than even powerline 600 solutions (60 Mbps real world) here.
Just throwing out some other options to consider.

1 Like

@DSAnduril Thanks for the tutorial.

At first glance it looked very promising. However, the tutorial required me to enable the tethering option before creating a bridge in connman. This used to work flawlessly when I tested it about half a year ago. Unfortunately, trying to enable it, currently results in an error. According to the log, permission to do so is denied. I’ve tried it again via command line with superuser privileges, but with the same result.

@darwindesign @Tom_Doyle:

Has ethernet to WiFi tethering been disabled in any recent update?

See "Error Enabling Hotspot" after October update - #2 by sam_nazarko

We’re still on 4.19. I’ve not heard of a fix since then.

Strange, I would’ve sworn that I got it tethering working in the summer, and I update fairly regularly.

Indeed, it seems to be working:

connmanctl> enable wifi
Enabled wifi
connmanctl> tether wifi on sstether sspass123
Wifi SSID set
Wifi passphrase set
Enabled tethering for wifi
connmanctl> technologies
  Name = P2P
  Type = p2p
  Powered = False
  Connected = False
  Tethering = False
  Name = Bluetooth
  Type = bluetooth
  Powered = False
  Connected = False
  Tethering = False
  Name = Wired
  Type = ethernet
  Powered = True
  Connected = True
  Tethering = False
  Name = WiFi
  Type = wifi
  Powered = True
  Connected = False
  Tethering = True
  TetheringIdentifier = sstether
  TetheringPassphrase = sspass123
connmanctl> quit

I can see the sstether SSID.

I just checked myself as well, going through the MyOSMC interface. Got an error the first time I tried, but then I remembered that in my current configuration I have the WiFi adapter disabled. Enabled WiFi, then it created the standard tethered WiFi hotspot just fine.

OSMC November 2020.11-1
Kernel 4.19.122-2-osmc

After some trial and error, I can confirm that the solution provided by DSAnduril can turn my Pi3 into a bridged WiFi access point, albeit with some caveats.

The lines in the original script:

eth_gw=`route -n | awk '/^ {printf("%s", $2)}'`
route add -net default gw $eth_gw

Lead to a concatenated address, which is obviously not understood. Unknown host

Replacing $eth_gw with allowed me to finish the script.

Another slight problem, Kore Remote no longer works, although it can still find Kodi on its original IP address on my network. I’ll let you know if I make any progress on that front.

If you don’t want to hardcode the gateway I think:

eth_gw=`ip r|awk '/default/ {printf("%s",$3)}'`

Should give you the right string (tested on only one case, so…).

My VPN gets in the way of testing this myself at the moment, going to have a set up a new SD card and play with it this weekend. Curious to see if you come up with anything on Kore.

I actually DO have a bridge from my router with a wired connection to my RPi 3+. It is relatively simple and works great with no slowness at all.

I use a dLink WET610N Bridge/Access Point in Bridge Mode which feeds from my Linksys 1200AC router through 2 wall to the livingroom. I have the RPi 3+, TV and NAS all connected to it with no problems. You will not get more than wireless AC speeds but I haven’t had a problem with any of the current video formats However, I haven’t tried any 4K files yet.