Broken SMB, Yatse & HifiBerry after update


I just updated my OSMC installed on a Pi B+, and I have totally lost control :

  • I cannot access the Samba shares anymore (my libraries are on a desktop) (and, of course, in precipitation, I said “ok” to clean all the unreachable items)
  • The HifiBerry DAC+ is not working anymore.
  • My remote app (Yatse) is not remoting anymore.

I didn’t changed anything else than updating.

Before that I haven’t updated for a while, because everything was working fine and because a I had a difficult exprerience with a previous update…

Is there something simple that I can do ? (The B-plan would be to reinstall Kodi on the desktop, but I would love to keep use of the pi…)

Thanks for your help.

How did you update? are the lines for the hifiberry driver still in config.txt?


Thanks for your help.
I did update trough My OSMC UI.
The line for the hifiberry is still here.

I managed to fix the remote issue by deleting and creating again the access to Kodi.
But I especially don’t know what to try about the SMB shares…

Sorry cannot help you with SMB, but does your hifiberry work now? FWIW, you need the lines:


Wonderful, thank you, the sound card is working again with the lines you gave.
Did I should have read these changes somewhere ?

For the SMB issue, I remind having the same issue a long time ago, doing some things server-side to get it working (about Windows guest access issues I think), but now, as I didn’t change anything except updating, I’m a bit lost…

Glad you got the HiFiberry sorted. Let’s hope someone else chimes in on SMB. I never use SMB myself.

I got it working !
It seems to be a common issue with an update on april, who seems to have disabled Guest SMB access.

I created an hidden account on Windows with the following bat and reg :

And set the correct credentials on OSMC (first by SSH, didn’t work, then trough the UI).

Is there anything I did wrong, or that I should do to have a better update experience ? It’s the second time, so I’ll be a bit frightened to do it a third time :confused:
Or… If it ain’t broke, don’t update it ?

Thanks AndersG anyway, and people involved in this awesomeness.

There was another update (OSMC 2016.5-1) a month later that undid what I mentioned above.

To this day I cannot access SMB shares. Please let me know if there is a solution. It’s really annoying using a USB drive constantly to get this to work :-/

The SMB changes were covered in some detail. Some changes in your environment may be necessary, but things should work fine.



I also have an issue with the Yatse app since the update from April. It can’t connect to Kodi.
Could you explain what steps you took the delete and creating the access again to Kodi.

Thanks for your

Delete the instance from yatse then recreate.

I did that already but it does not work.

Does Yatse identify your OSMC automatically and you can not connect or is it not showing up at all?
If it is not showing up at all check your settings if you may have disable the control server or changed the port.

At first sight Yatse tryes to connect automaticly. The second stage is that I give it my osmc IP address and port to commnunicate with. Also with these manually added setting it cannot connect to my osmc. I tryed port 80, port 8080 and port 9090. During the first installation in March it found my osmc without any interference from me.
I use the Yatse version 4.3.6 for Androids 2.3.6 on a Samsung smartphone.

I tryed to use the remote control build into Kodi with my OSMC IP address. It could not connect to the remote control website. So I checked if the smartphone was connected to my local network. And indeed for some reason it was not connected to my local network. After connecting my smartphone to my local network I was able to connect to the remote control website. Then I started Yatse and wonder O wonder Yatse found the osmc device and now the Yatse app works again. For being complete it connects to port 80.

So my problem is solved. Thanks for you time.

[quote=“sam_nazarko, post:9, topic:18571, full:true”]
The SMB changes were covered in some detail. Some changes in your environment may be necessary, but things should work fine.

[/quote]Could you provide a link to that. I spent almost a week trying to resolve this issue a while back :frowning:


Click the search button and type ‘Samba’?

Sorry that just references things that I have tried in the past or my own solution that does not work for me any longer :frowning: