Brought OSMC Rasp Pi kit and Wifi Dongle is not registering

Hi Guys,

I brought the raspberry pi starter kit from the OSMC website, however after installing OSMC I am unable to activate the wifi dongle. i.e. it doesnt show up in the network settings.

The Dongle was shipped out by the guys as OSMC so I assume it should work.

It has 802. 11n printed on it.

Any help would be really appreciated.

Many THanks

MAtt

I’m puzzled - you talk about installing OSMC, but the starter kit comes complete with a pre-loaded SD card with OSMC.
Derek

Hi,

Sorry I was just referring to the fact that first time you load up the pi with the sd card it installs the operating system. After the first boot it automatically takes you to osmc.

I have been playing around in terminal and the wifi dongle shows up when i use the dmsg command.

However when I try

osmc@osmc:~$ connmanctl
connmanctl> enable wifi

I get the line

error wifi: method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

Any ideas?

Cheers

Sorry Im a bit of a newb to this.

Cheers

Matt

Did you attempt to use the MyOSMC Settings addon in the GUI that is included in every installation?

Yeah,

That was my first port of call.

Under the network setting:

It only shows an option for wired, then when I click enable adaptor it either says status disabled or no wired connection.

Perhaps Im missing something there?

Hi,

Occasionally we change the chipset in the WiFi dongle. My guess would be that the version that came preloaded is out of date (we image them with the previous month’s update so if anything is wrong we have time correct the issue). If you give me the order number I can probably confirm that for you.

There are two ways to remedy this:

  • You can go to osmc.tv/download and choose the latest image. This will involve re-loading the SD card.
  • Alternatively, if you’re able to, attach an Ethernet cable temporarily to the Pi, go to My OSMC -> Updater. Check for updates and let the system upgrade.
  • Then shutdown your device (select Power -> Shut down) and unplug it. Remove the Ethernet cable and turn the Pi on again.
  • You should now have more joy in My OSMC -> Network Settings

Sorry about this

Sam

Thanks Sam.

I have downloaded the update and followed your instructions , so now it says the I have a version that was updated in August.

Unfortunately I still can not get my wifi to register.

The router is now next to the pi, and my laptop is logged on working fine.

Here are some pics of terminal, I dont know if this may help anyone to diagnose the problem.

dmsg command

This is the network page in my OSMC without the ethernet plugged in.

Any help greatly appreciated!!

I see the issue here. Thanks for the dmesg. That was quite helpful.

The issue was caused by the fact the firmware for the wireless adapter is missing. I have added the firmware and pushed it out as an immediate update. If you connect the Ethernet cable once more (I do apologise for this), and upgrade again, you should hopefully be able to use your WiFi stick.

In the next update, support for the dongle will be included in the disk image directly

Sam

Thanks Sam,

Sorry to keep you busy but still no joy.

I have just tried changing the channels on my router too to see if that made a difference

Heres an updated dmesg

there still seems to be a firmware message under the dongles bits.

let me know what you think.

Cheers

Matt

Did OSMC install an update?

Try running ls /usr/lib/firmware/mt6701u.bin to see if you have the file. Further, what is the output of dpkg -l | grep wireless-firmware-osmc

Sam

Hi, yeah I installed the second update. Just checked again and there is definitely no other updates available.

Here are the outputs you wanted.

I assumed that the line/break between dpkg -l and grep means enter? sorry pretty new to this.

Here are the pics

The dpkg -l | grep refers to a pipe. This is next to the shift key for me.

The firmware file should be case-sensitive, so if you update again now for a final time it should be fixed! If not, I’ll grab a dongle in the morning and have a closer look

Sam

Thanks,

Sorry but still no joy.

Will check back tomorrow.

Cheers

Matt

Have u had any breakthroughs at all Sam?

Many Thanks

Matt

Hi

Yes I have :smile:

If you upgrade now, it will work. Sorry about all of this

Sam

Hi

So, I have reinstalled osmc from the end of August build on my rpi 2 and performed an update. I am still having some issues with the MT7601 wifi dongle. Grateful if someone could help with that. Below are link to log extract that can help with the debugging:

uname -a
http://paste.osmc.io/docololeta.pas

lsusb
http://paste.osmc.io/royaqaxaso.vhdl

lsmod
http://paste.osmc.io/edalowukeg.hs

dmesg
http://paste.osmc.io/vaxuyoliti.vhdl

ifconfig -a
http://paste.osmc.io/haxewejite.sm

Thanks
Delvin