[Buffer issue] Playback a movie and fast forward?


I’m streaming my movies though SSH using filezilla.
I have to say that I know this issue with AVI files and it’s basically normal with AVI or MP4.
Here it’s a MKV file and as I said I can seek into the movie, but it takes upto 5-10 minutes to reach the 50th minute of the movie.
It’s definitely not a problem of file since I can seek and read my MKV from my laptop directly using kodi. The problem occurs only when I’m using OSMC with a raspberry pi, that’s why I suspect a buffer issue/bad configuration.

I can read the movie from the beginning when it is downloading.
But I can’t fast forward in the part of the film which is downloaded…
Actually I notice that I can forward sometime, but some other time I can’t.

I think that I have a buffer issue when I try to buffer data currently coming from the web.
Precisely I copy the file from a NAS server (located at my
parent’s house though SSH) to a computer which broadcast a SMB server to OSMC.

I already try to directly connect a NFS sharing directly from my parent’s house, but it’s worst than the current solution.

I mean there is no trouble about my configuration with 3 different
laptops when I download the movie and I play it back directly. I can
seek without trouble. Only with OSMC and the raspberry pi it’s seem to
have this playback issue when I seek into my file. Maybe there is
something to do with the advancedsetting.xml file ?

Do you get the same behavior with any other Kodi distro for raspberry pi?

Hello ActionA,

What do you mean by other kodi distro, like OpenElec ?
I will try tomorrow with that distro. And tell you the result :slight_smile:

Hello ActionA,

I just tried 5 minutes ago. Same problem with differents MKV movies with OpenElec.
What does it mean ? I guess it’s not related to OSMC, but directly the Kodi software ?


Btw, I tried with 2 same files:

  • One downloaded.
  • One during the download.
    The problem is really related to the fact that I try to seek a file which is downloading.
    (Seeking in the range of time, which is downloaded of course)

As pointed out in the github issue you posted what you are trying to do will not work reliably so you are wasting your time trying to “solve” this. I suggest that you find an alternative method of streaming your media, such as using sshfs to connect to the original source directly instead of using your PC as an intermediate.