Buffer issues after October Update

No – but I do believe we should adjust advancedsettings.xml for Vero 4K, as we have more memory to play with. I’d like to get some sane values established and included in the next update.

I’d like to weigh as I recently had some issues with playing back a high bit rate file (nearing 90 Mbps) while other high bitrate files where playing fine. For me mounting the shares with fstab instead of nfs directly helped alleviate these issues. I’m using a buffer of about 190 MB with a read factor of 6, and my files are on a QNAP NAS.

In the past (a few months back) I kept having buffering issues which were the result of making the buffer too large. They went away when I lowered them.

1 Like

Thanks for the feedback.
Can you paste the full advancedsettings if you’ve made any other changes?

Sam

The only things of relevance in my advancedsettings.xml are

 <network>
	<buffermode>1</buffermode> 
	<memorysize>190000000</memorysize>
	<readfactor>4</readfactor>
</network>

I see I misremembered the read factor.

There’s also some path substitution so I didn’t have to change my original sources when changing to fstab.

Hi Pleomin,

As of kodi 17, the flag has been replaced with so your advancedsettings.xml should be:

<cache>
	<buffermode>1</buffermode> 
	<memorysize>190000000</memorysize>
	<readfactor>4</readfactor>
</cache>

Thanks Tom.

good to know

I’ve play with for/back (same cache settings) and now i’ve the issues image/movie freeze, but Kodi run all ways
here is the log https://paste.osmc.tv/owihefigom

free -m

>               total       used       free     shared    buffers     cached
> Mem:          1789        766       1022          8         22        195
> -/+ buffers/cache:        548       1240
> Swap:            0          0          0

Film Cent mille dollars au soleil time 15:25

I’ve been using the following settings since February, without issue:

<advancedsettings>
	<cache>
		<buffermode>1</buffermode>
		<memorysize>536870912</memorysize>
		<readfactor>20</readfactor>
		<curlclienttimeout>10</curlclienttimeout>
		<curllowspeedtime>10</curllowspeedtime>
	</cache>
</advancedsettings>

I figured using 512mb of cache would be fine, since the Vero has so much free memory available, and it’s been working great. When watching my own videos or streaming something from an add-on, my entire cache fills up rather quickly and I never experience any buffering, no matter the file size.

I was suffering from 4k files stuttering and audio drop outs after a few minutes. On bringing up the process info panel in Kodi (o key) - I could see that the player cache would end up a 0% full when the issues would occur.

I went for

<advancedsettings>
<cache>
	<buffermode>1</buffermode>
	<memorysize>256000000</memorysize>
	<readfactor>6</readfactor>
</cache>

Post that change i can play all my 4k files (including 60fps / HDR) without issue and the player cache stays at 100% full.

Thought i would share as more evidence for tweaking the defaults for Vero 4k :slight_smile:

Good man.

Thank you for your feedback. It will definitely help us improve things out of the box.

Hi
I try memory 256xxx with the same movie and my play back/forw stress test. It’s works.
But I cann’t send you the logs @sam_nazarko

osmc@wst11:~$ grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/<html>
osmc@wst11:~$ 

I think that i’ve see this message in the past but I don’t remember.
I wait for the solution to send the logs, then I try with a “fresh” movie recorded, but never played.
A+
Michael

Might be that your logs are too big.

Try rebooting a couple of times to generate a fresh new log.

That’s right for the size the Kodi log 16.5 Mo
The log is “fresh” the box started at 15:39
but some components debug are enabled, and if I disabled this…
Michael

Don’t think you need component specific logging, it’s surely the reason why logs are so big.

Disable that option and you should be able to upload logs.

Hey frankiej, why not try the settings I posted above yours? The cache size will be doubled, and with the readfactor improved, Kodi will work faster to fill the cache up. These are ideal settings for people playing large files with an internet connection that might not handle continuous playback without caching.

For me

  • nfs,
  • Vero4 <-> wired Lan <-> NAS
  • mostly ripped DVD or recorded TS files H264

this cache settings works fine

 <cache>
                <memorysize>25600000</memorysize>
                <buffermode>1</buffermode>
                <readfactor>5</readfactor>
        </cache>

Yesterday i see a Kodi warning like “buffer writing to slow” for that i change readfactor from 6 -> 5

Now Video playback work’s fine also for recorded movies with pub which need use from forward/backward.

I’ve some other issue I think with

[swscaler] No accelerated colorspace conversion found from yuv420p to bgra.

I open another thread for that.

Merci a tout

Michael

I hope that it is okay to bump this thread. I have tried the different cache settings posted in this thread, however, they do not fix my issue.

I have tried to set the readfactor to different values such as 4 (default), 5, 10, 20, 30, 40, 50, 100.
I changed the cache as well from default to numerous values as posted by you guys ranging from 200 MB to 2000 MB.

I rebooted the unit with “sudo reboot” or via the UI between the changes. I pressed CTRL+SHIFT+O to check the buffering. For some reason the forward buffer goes up to 192 MB when the buffer is at 500 MB if I recall correctly.

The Vero 4k plays back the files without problems when they are in the buffer.

I took my laptop next to the Vero 4k and tried to copy the same file 4k HDR file and it said it would take 28 minutes to transfer it. The file is 120 minutes. They are both connected to the same 5 GHz 802.11ac network (my 2.4 GHz has a different SSID so that is not the issue). The Vero 4k does not really “want” to transfer more than 30-40 Mbit/s. Therefore, low bitrate files can play without buffering issues. This means that my Vero 4k cannot playback 4k without buffering issues.

I use fstab to mount the network drive. Before I used the Vero 4k I installed the updates.

What have I done wrong? Or is there an issue with my Vero 4k?

Fundamentally, this seems to be a WiFi issue.

On ethernet cable, you’d expect to see around 95 Mbits/sec, pretty much guaranteed, but WiFi throughput is far more susceptible to external factors. Please note that 5 GHz is no guarantee of better performance over 2.4 GHz since it can be more affected by physical obstructions such as walls. If ethernet cable is simply not possible, you might find that changing the position of the Vero4K will help, as might trying the 2.4 GHz band.

FYI, the forward video buffer will be up to 37.5% of the configured buffer memory size, with an additional amount for audio buffering.

It is not possible to connect it with a cable.

How can this be a Wi-Fi issue? My laptop on the same Wi-Fi next to the Vero 4k can copy the 120 minutes file in 28 minutes that the Vero 4k cannot play without having to stop and buffer.

FYI the laptop has an i7-4500U so it is 4 Intel CPU generations old and has better Wi-Fi than a Vero 4k.

I could try the 2.4 GHz SSID I have.

Why does the buffer only go up to 37.5% of the buffer size?

Indeed. Until the WiFi performance is improved, no amount of tweaking will help, nor can it be considered necessary

Sam