Buffering issues

I seem to be having terrible issues playing back 4k UHD rips. These are not recompressed so pretty high bitrate.

I’ve tried wired connection which goes back to my Synology NAS server.
All my other devices stream / copy data from my NAS server pretty fast and have no issues, so I’m wondering what I could do to try and get it working on the Vero4k. I have had doubts whether the 100Mb connection is sufficient but people have frequently said it’s not a problem.

I’ve also tried the wireless and that’s a lot worse - less than second of video before audio drops, video freezes and buffering message appears.

I’ve tested my cables and everything - if I connect my laptop, the port runs at GbE speeds, obviously it slows to 100Mb when plugged into the Vero4k box.

If it turns out the bitrate of some of my 4k UHD rips is too high for the Vero4k to run, then it’s a real shame as I bought this box specifically for 4k playback…

So any suggestions?

How are your shares mounted?

Is this a 4K or 4K+?
For the 4K model, 100Mbps should suffice, but you will benefit from OS mounts. See File sharing with a NAS, media server, windows share or other device - General - OSMC.


With very large rips the system mount seems to make a huge difference. That would be the part in the guide Sam posted above titled “OSMC as a client – using fstab or autofs”.

Thanks Sam. Your replies seem to arrive faster than the stream from my server!

Yes, I’ve tried mounting via fstab, but I’ll read your linked post and report back.

What is the Bitrate? You can check with mediainfo

It’s the UHD Blu-Ray of Terminator Dark Fate.
Format : BDAV
Format/Info : Blu-ray Video
File size : 55.0 GiB
Duration : 2 h 8 min
Overall bit rate mode : Variable
Overall bit rate : 61.5 Mb/s
Maximum Overall bit rate : 109 Mb/s

With Kernel Based mounts that should be fine.
Maybe login via SSH and try to copy the file to /dev/null to measure the time that will show you if continuous reading works.

time cp /mnt/server/file /dev/null

OK, so I’ve done some testing. Bearing in mind I’m currently using the built-in WiFi, I have a couple of questions side-questions.

I see from this post: Vero4k Networking - #2 by sam_nazarko that I should be getting around 200Mbit/s speed.

Having mounted an NFS (for best performance?) share from my Synology server using autofs, and doing a time cp /mnt/server/file /dev/null, a 46MB file takes 14s to copy, so that’s around 3.3MB/s so way off a 200Mbit/s speed.

My wireless router is a Hitron (on VirginMedia Business in the UK) offering 802.11 a/c/n speeds, so I should be getting something better.

Also, is there an easy way to configure the network from SSH that’s compatible with the OSMC Program app from the GUI? I’d prefer to configure the network remotely as doing it through the GUI is a pain.

I don’t want to be distracted to using WiFi if cabled is best, but it looks like the WiFi on the Vero4k is potentially faster than the 100Mbit wired port, I can use either. The Vero4k is directly below my WiFi router and has many dots in the GUI indicating a strong signal I guess.

Well to figure out the real speed iperf3 is your friend: [How To] Check Network Performance with iperf3

Do you have seperate SSID’s for 2.4 and 5Ghz wifi? If not you might actually be connected to your 2.4 Ghz network

You can configure from command line with connmanctl but surely while you are logged in via SSH it might be tricky to change your network connection as you might loose connection.

Being that close can lead to interference that lead to connection issues.

I would stick to cable as it should be good enough with the Kernel mounts.

Right, my WiFi for some reason is woeful.
Connecting to host, port 5201
[ 4] local port 46837 connected to port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 2.98 MBytes 25.0 Mbits/sec 20 14.3 KBytes
[ 4] 1.00-2.00 sec 1.85 MBytes 15.6 Mbits/sec 8 15.7 KBytes
[ 4] 2.00-3.00 sec 1.80 MBytes 15.1 Mbits/sec 8 18.5 KBytes
[ 4] 3.00-4.00 sec 2.05 MBytes 17.2 Mbits/sec 9 18.5 KBytes
[ 4] 4.00-5.00 sec 1.68 MBytes 14.1 Mbits/sec 14 12.8 KBytes
[ 4] 5.00-6.00 sec 1.79 MBytes 15.0 Mbits/sec 13 12.8 KBytes
[ 4] 6.00-7.00 sec 1.89 MBytes 15.9 Mbits/sec 9 11.4 KBytes
[ 4] 7.00-8.00 sec 1.69 MBytes 14.2 Mbits/sec 11 15.7 KBytes
[ 4] 8.00-9.00 sec 1.78 MBytes 14.9 Mbits/sec 15 11.4 KBytes
[ 4] 9.00-10.00 sec 1.80 MBytes 15.1 Mbits/sec 11 12.8 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 19.3 MBytes 16.2 Mbits/sec 118 sender
[ 4] 0.00-10.00 sec 18.7 MBytes 15.7 Mbits/sec receiver

Via cable, it’s a lot better, and pretty much at 100Mbit/s

[ 4] local port 52587 connected to port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 15.1 MBytes 127 Mbits/sec 0 222 KBytes
[ 4] 1.00-2.00 sec 11.4 MBytes 95.3 Mbits/sec 0 269 KBytes
[ 4] 2.00-3.00 sec 11.2 MBytes 94.2 Mbits/sec 0 269 KBytes
[ 4] 3.00-4.00 sec 11.3 MBytes 95.1 Mbits/sec 0 271 KBytes
[ 4] 4.00-5.00 sec 11.4 MBytes 95.3 Mbits/sec 0 271 KBytes
[ 4] 5.00-6.00 sec 11.4 MBytes 95.3 Mbits/sec 0 271 KBytes
[ 4] 6.00-7.00 sec 11.3 MBytes 95.0 Mbits/sec 0 271 KBytes
[ 4] 7.00-8.00 sec 11.2 MBytes 94.2 Mbits/sec 0 271 KBytes
[ 4] 8.00-9.00 sec 11.3 MBytes 95.3 Mbits/sec 0 271 KBytes
[ 4] 9.00-10.00 sec 11.2 MBytes 94.2 Mbits/sec 0 271 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 117 MBytes 98.1 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 113 MBytes 95.1 Mbits/sec receiver

So I’m now back on the cabled connection.

Also, now that I’m using autofs, how should I then see the shares on OSMC? Should they appear in the auto mount menu? (They don’t!). The article was great in adding the shares from the CLI, but then doesn’t clarify how you get to access them in the GUI.

Under root Filesystem - mnt - and then the folder you configured

Thanks fzinken. For some reason, OSMC didn’t list them under /mnt/ despite them being there. A reboot seems to have fixed it.
I need to play around a bit more, but the few tests I’ve done now seem to work OK and don’t seem present stuttering or buffering issues. :slight_smile:

Another question: there are many instances of the actual “share”:

  • the share folder on the source server
  • how that share is mounted in the Vero4k’s OS (for example, /mnt/mount-name)
  • what share name is given to that mount within OSMC.

So, the “share name” given in OSMC, can this be the same across different sources?

smb:// mounted as /mnt/server100/share100 then within OSMC, is given the name “share”
Then, on my second server, I have
nfs:// mounted as /mnt/server101/share101 then within OSMC, should / can I give it the same name, i.e. “share” ?

I don’t see what purpose the OSMC share name provides?

You would need to remove your original Kodi mount (smb://) to avoid using that.

Is that a second server? You should on all clients mount the server shares under the same path.

No, first one on has a CIFS / Samba share. Second one is a different server, having an NFS share.

Or are you suggesting that I could mount different servers in the same path, so the /mnt/share or whatever ends up being the accumulative result of all the shares?

edit for example:
smb:// mounted as /mnt/share
nfs:// ALSO mounted as /mnt/share

No different servers (with different data) should be mounted in two different folders.
Just remove your original smb://source from Kodi/OSMC and you are done.

Yes, sorry, I over simplified in the examples.

I now have an /etc/auto.nfs.shares :

and a Samba share: /etc/auto.smb.shares :
/mnt/xavier-pc/share -fstype=cifs,ro,username=media,password=media,vers=3.0,iocharset=utf8,uid=osmc,gid=osmc ://

What I wasn’t sure of was the name given to those mounts within Kodi/OSMC. After going into the “browse filesystem” and nagivating to those mount points, Kodi/OSMC still asks for a name for the share and I wondered why as it seems to serve no purpose. And whether THAT name could be the same or whether it also has to be different / unique to each mounted share.


Each share should have a different name.

Thanks Tom.

You could, I think, have a single Kodi video source pointing to /mnt, which could search recursively through both mounted folders. (If you really want to).

The reason why you have a separate name for the Kodi source is just so you can call it something descriptive. You need separate sources for movies and TV shows, for example, so you might want to have a Kodi source called “TV” (or whatever) even if the folder name is something else.

And not all Kodi sources are based on folders - they might be based on a DLNA server, for example

In the file manager those are basically just shortcuts and that is why it asks for a name if you go to add one. This part of Kodi is seperate from the rest of Kodi. As for your library, which is the part you set in Videos, they ask for a name as you are setting up sources. You can have more than one file path in a source. What they are named doesn’t matter.

That being said you should understand exactly what you want to do. If you setup new sources for you library and leave the old ones then all your content will be duplicated. If you change your current shares to the local paths your content will be duplicated. If you want to make it so your library uses the system mounts instead you must either dump your existing library and scrape new or alternatively leave your sources exactly as they were and use path substitution to seamlessly redirect the paths in the background…