Buffering & lagging after transition from ethernet to Wifi


#1

Hey there!

Recently moved to a new apartment, which does not allow me to connect my Vero 2 to my router via ethernet. After switching over to wifi I am experiencing a lot of buffering and lagging. I am thinking this simply is a bit-rate issue? My router is not strategically placed for optimal signal strength either, I am afraid.

Anyhow… Maybe these provided logs make it possible for more experienced users to validate my diagnosis (poor wifi-connection) and perhaps give me some solutions to my problems. I recently ordered a stronger wifi-dongle to be able to connect the Vero to my 5ghz, and I am thinking about simply going for the Vero 4K, but is there something else I can do in the mean time to solve this problem?

Logs: https://paste.osmc.tv/ihutepaqoh


#2

Poor wifi you best can determine by installing wavemon sudo apt-get install wavemon


#3

You seem to be using NFS.

If you do an fstab based mount, you should get better performance.

Sam


#4

Thanks! Here is the output:

LEVELS
Link quality: 100%
Signal level: 63 dBm
Noise level 0 dBm

STATISTICS
RX: 152 632 (218,52 MiB), invalid: 0 nwid, 0 crypt, 0 frag, 0 misc
TX: 90 304 (10,63 MiB), mac retries: 0, missed beacons: 0;21H

INFO
mode: Managed, access point: 9C:5C:8E:C3:1D:68, sensitivity: 0/0
freq: 2,437 GHz, channel: 6, bitrate: 150 Mbit/s │
power mgt: off │
retry: off, RTS/cts: off, Frag: off │
encryption: no information available

So what does this tell us? That the signal is weak but the quality is good. But how do I see if the signal is enough for streaming video content?


#5

Right! So after som googling I figured this simply consisted of adding the mount in fstab and then adding the videos in Kodi through “root folder”, right?

I settled on this configuration in stab (found in similar thread):
192.168.1.3:/export/tv /mnt/tv nfs noatime,noauto,x-systemd.automount,async,nfsvers=3,rsize=8192,wsize=8192,nolock,nofail,local_lock=all,soft,retrans=2,tcp 0 0

I can see a slight difference when playing videos, but it is still buffering and lagging.

Is this a lost case? As I wrote my friend has ordered a 5ghz wifi-dongle that will put an end to this hopefully in some weeks, but it would be nice to get this going before that.


#7

Hi

2.4Ghz 1x1 40Mhz will, under the best of conditions get you 40Mbps in the real world.
This is good enough for most Blu-ray rips, but again, this is under perfect conditions.

An iperf test would let you know what kind of speed you are currently getting.
If you get an 802.11ac dongle for Vero 2, make sure you get a compatible one. We added 802.11ac to the 4K. 802.11n is good enough for 1080p but not good enough for 4K.

Sam


#8
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
[  4] local 192.168.1.3 port 5001 connected with 192.168.1.16 port 44270
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-16.3 sec   896 KBytes   449 Kbits/sec

  • Client connecting to 192.168.1.3, TCP port 5001
    TCP window size: 20.7 KByte (default)

    [ 3] local 192.168.1.16 port 44270 connected with 192.168.1.3 port 5001
    [ ID] Interval Transfer Bandwidth
    [ 3] 0.0-12.7 sec 896 KBytes 580 Kbits/sec

Am I reading this right that I have got one tenth the bandwidth I would need? :slight_smile:

I really appreciate that you are taking your time to nudge newbies like myself in the right direction!


#9

A lot more than a tenth :wink:

Those speeds are abysmal.

Something might not be right environmentally. The Vero 2 has pretty good WiFi reception (the antenna is quite long). Do you have the opportunity to change WiFi channel? How far are you from the router?

Cheers

Sam


#10

Right. I will never get the mbit/mbps-lingo right! :smile:

The environment is horrible. The router sits in my hallway since that is where the ethernet comes in. The Vero is obviously in my living room. The result is that the signal from the wifi has to go through two thick concrete walls.

The thing is that my Samsung TV manages just fine.

Yeah I could change the channel. Currently I am running 40mhz and the channel set to “auto”. Is there something to prefer here?


#11

What’s the Samsung TV doing?
Perhaps it’s 5Ghz and not as heavily afflicted.

Usually you can check for neighbouring networks and their channels.
Try pick a non crowded channel


#12

The Samsung is on a 2.4ghz network and is streaming Youtube, maybe the two cannot be compared.

Yeah so I changed the channel. Hm. It seems that we are at roads end with this. As I see it I have the following options:
-Reinforcing the Vero 2 with a 5ghz Wifi-dongle
-Buying the 4K
-Somehow changing the location of my router

But I want to thank you for your help! I´ve learned a thing or two along the way!


#13

You can also try repositioning the Vero 2 slightly, and it may yield some improvement. But I don’t expect there to be a big difference.

However we did have complaints with Vero 1’s WiFi (which was mainly software related), and since then we’ve made sure that this is an issue of the past with future models (including Vero 2).

Sam


#14

5GHz will do it for 1080p content usually without problems, unless it it uses a very high bitrate (same for 4K). Also depends if you have an 11n or an 11ac network and what modes are supported - also you never get the theoretical maximum rate anyway.

Using fstab or not will not really make a difference at all. Same for NFS or SMB. The slight overhead is rarely causing the issues in properly setup network and service when you already have setup a buffer in Kodi. But mount your shares anyway, doesn’t hurt - but will not solve your problems magically.

TLDR; 5GHz should work for you. 2.4GHz will cause you a lot of problems even on 1080p stuff. Preferable an 11ac and not an 11n Wifi.


#15

Well that will not get better with 5Ghz. The advantage of 5Ghz is more speed and (currently) less congestion. But as it has a higher frequency going through walls (especially with steel) is less perfect.

I normally use a wifi analyser on my phone to see which channels are less congested. You have to do that from time to time as your neighbours channels might change


#16

It makes a massive difference.
It’s not about the overhead of userland, but rather the fact that the kernel can perform readahead. This means when you do get a drop in connectivity, kernel based mount will be much more likely to recover.

For 4K content, you will benefit tremendously from such a mount. 1080p less so.

I wouldn’t say so – you’ll find Vero 2 users on the forum able to constantly achieve 30-40Mbps. Most 1080p content watched is far below this.

Indeed.


#17

Unless you’re 100% sure there are no neighbours using WiFi, you should not choose 40 MHz bandwidth. In a residential area 20 MHz is the only realistic option. Also, always choose a fixed channel - and only 1, 6 or 11. Trying to choose a channel in between your neighbours just makes things worse both for you and for your neighbours. Unfortunately, most neighbours don’t know this. :frowning:

It looks like you used iperf for your test. The latest (and greatest) version is iperf3 and it is a lot better than the original iperf. You’d need to run iperf3 at both ends but it can also show things like the number of packet retries, as well as a more accurate measurement of data throughput. The iperf figures are at odds with those from wavemon, so perhaps there is scope for improvement. Wavemon’s signal level of 63 dBm is acceptable.


#18

Ahhhm … no! Sorry for the following comment:

The thread opener shows in his log

Current default time zone: 'Europe/Stockholm'

In Europe we’re using 20 Mhz channels 1, 5, 9 and 13 in the 2.4 GHz band since these have no overlapping.
The US guys have problems using channels 12 and 13 und it was even not allowed some time in the past. That’s why they used a long time 1, 6 and 11 … but this scheme waste a complete channel in Europe.

But of cause this only helps if ALL neighbours are using the same channel scheme. Once you have an ignorant one using any channel in between 1, 5, 9 and 13, you have a problem.

Sorry again for the interrupt in this thread.


2.4 GHZ WiFi slow
#19

Thanks for the input.

I’m also in Europe (UK) and am aware that there is a debate about what is best. While 1/5/9/13 might work in a controlled environment, there are real problem with this approach:

  1. Most home routers seem to ship with a default channel of 1 or 6, even in the UK; and

  2. Anyone who does take the trouble to check up via a search engine will see that the vast majority of sites recommend 1/6/11.

Perhaps I should have qualified my recommendation but in my experience (and clearly YMMV), sticking with 1/6/11 is less likely to be affected by channel overlap than going for 1/5/9/13.


#20

Perfect comment, want to make an amendment to it and say that the user should install an wifi analyzer app to check with channels are used and pick the one least used and apply channel with 20/40 mhz along with space block code if it is a messy environment :slight_smile:

Wifi is always a best effort service :slight_smile:


#21

Hey guys!

I just wanted to let the people that contributed to this thread know that I settled for a Vero 4K during Black Friday. I’m looking forward to it arriving very much and hope it will solve my problems since it supports 5ghz. Thanks!