Cabled Ethernet stop working (Vero 4K +)

Hi Folks,
in my Vero4K+ the cabled network stop working (WiFi is still ok), it’s disabled in MyOSMC conf, recieving an exception if i try to enable it.

using ssh over wifi same result:

connmanctl> technologies
 Name = P2P
 Type = p2p
 Powered = False
 Connected = False
 Tethering = False
 TetheringFreq = 0
 Name = WiFi
 Type = wifi
 Powered = True
 Connected = True
 Tethering = False
 TetheringFreq = 2412
 Name = Bluetooth
 Type = bluetooth
 Powered = False
 Connected = False
 Tethering = False
 TetheringFreq = 0
connmanctl> enable ethernet
ethernet is not available

here some logs

Any hint? maybe an hardware failure?

P.S. Sorry for my bad english i’m not a native speaker/

These aren’t full logs so hard to say.

First thing I’d suggest is a full reinstall of OSMC.

Just formated using this guide Reinstalling OSMC - Vero 4K - OSMC (usb pendrive), same issue occour, no cabled network enabled and some sad smile reboot (5 times in a row) after formatting, here some freshlog:

if you need more details/logs can you explain me how to grab them for you?

Power Supply issue? Do you have a spare power supply with same specifications?
Or can you try to power it with a USB A-A cable (no power supply connected)?

Unfortunately I don’t have any other psu or a male/male USB A cable.
I’ve always used the original adapter, is it possible that now it only compromises eth0 interface and not the wifi?
I will buy the usb cable, to connect to the white port, correct?

Possible yes, but not most likely.
I was assuming that more from the fact that you had 5 sad faces on a fresh install

Changed psu but the problem persists :frowning:
No eth network and cannot enable it

This doesn’t look good:

[    1.442563] libphy: stmmac: probed
[    1.442568] eth%d: No PHY found

and could be indicative of some hardware issue.

Do you know when it stopped working?


On August 14th i noticed that the clock was out of date and that it no longer reached the NAS.
I don’t know exactly when it started to malfunction, it has been at least a week without me using it.
it has always been connected to the ethernet network as well as to the electricity network in these two years of use. No tampering or DIY hacks whatsoever.

Did you have a surge or bad weather recently?

It’s odd – and I haven’t seen this one before where the Ethernet just stops working after some time. When you plug the Ethernet cable in, do you at least see a light on the switch or router that it is connected to?


no surges

nope, zero signal form the switch or the router

maybe an overheating problem? it was always very warm 70-80C

70-80C isn’t anything to be concerned about.

You could open the device and check nothing’s broken off and try and clean with contact cleaner. But the fact that the PHY is not detected at all is worrying.

Gently opened and removed the single board, everything looks fine, no desoldering, no burn marks or strange smells, cleaned the contacts with pure isopropyl alcohol.
Nothing change :frowning:

I’m sorry to hear that. You can contact and we can look in to what can be done.



I have the same problem. I use mount with a fstab. All was working some times ago.
I used putty to connect to the Vero, and this is the output of the command ‘mount’
systemd-1 on /mnt/films type autofs (rw,relatime,fd=48,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=13470)

And this the line in fstab : /mnt/films nfs ro,noauto,x-systemd.automount 0 0

Just did this :
osmc@osmc:~$ showmount -e
clnt_create: RPC: Unable to receive

Thanks for help

I don’t think that you have the same problem if you connect via SSH.
Suggest to upload logs via grab-logs -A and share the URL.

Hello Lucas,

Please start your own thread outlining your symptoms fully and providing full logs.

Please see How to submit a useful support request - General - OSMC.

Your issue may not necessarily be related to the issue reported by coboye. To ensure that both they and you are able to get their issue resolved, we would like you to start a new thread for clarity.

OK, thanks I will do